RuntimeError: tf.placeholder() is not compatible with eager execution.(亲测有效)

今天运行Tensorflow时,出现以下错误:

RuntimeError: tf.placeholder() is not compatible with eager execution.

原因是下面这个语句:

x = tf.compat.v1.placeholder(tf.float32, [None, 784])

这个语句需要在session前定义,在session中执行,但在使用T的ensorFlow 2.0及以上版本中,默认情况下开启了紧急执行模式,即定义即执行。

所以,我们需要在上面的语句前定义一下它不着急执行,有两种解决方案:

方案一:

添加 tf.compat.v1.disable_eager_execution(),即:

tf.compat.v1.disable_eager_execution()
x = tf.compat.v1.placeholder(tf.float32, [None, 784])

方案一参考处

方案二:

添加tf.compat.v1.disable_v2_behavior(),即:

tf.compat.v1.disable_v2_behavior()
x = tf.compat.v1.placeholder(tf.float32, [None, 784])

方案二参考处

  • 24
    点赞
  • 48
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值