翻译布尔表达式

翻译布尔表达式
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
大家都学过了布尔表达式的翻译,其中有一个拉链-回填技术,这次我们就练习这个技术。

Input
多组输入,首先输入一个整数T,代表数据组数。

接下来每组输入为一行字符串,例如: a < b or c < d and e < f

每个符号都用空格间隔。

Output
假链跳到0,真链跳到1,表达式序号从100开始排。

Sample Input
1
a < b or c < d and e < f
Sample Output
100(j<,a,b,1)
101(j,,,102)
102(j<,c,d,104)
103(j,,,0)
104(j<,e,f,100)
105(j,,,103)
Hint
Source

#include <iostream>
#include<bits/stdc++.h>
using namespace std;
vector<string>ans;//暂存每一个and or相隔的部分:eg: a<b;c<d;e<f;
string s;//存整体
int t, f;
int main()
{
    int n;
    scanf("%d\n", &n);//???
    while(n--)
    {
        getline(cin, s);
        s += " end";//???
        t = 1, f = 0;//t是true的地址, f是false的地址//???
        int id = 100;//地址起始
        string x;//空格隔开的每一个小部分
        stringstream ss(s);//整体//???
        while(ss>>x)
        {
            if(x == "or")
            {
                printf("%d(j%s,%s,%s,%d)\n", id, ans[1].c_str(), ans[0].c_str(), ans[2].c_str(), t);//转去true
                t = id;//下一个true的跳转地址就是这个
                id++;
                printf("%d(j,_,_,%d)\n", id, id+1);//转向顺序中下一个地址
                id++;
                ans.clear();//???
            }
            else if(x == "end")
            {
                printf("%d(j%s,%s,%s,%d)\n", id, ans[1].c_str(), ans[0].c_str(), ans[2].c_str(), t);
                id++;
                printf("%d(j,_,_,%d)\n", id, f);
                id++;
                ans.clear();
            }
            else if(x =="and")
            {
                printf("%d(j%s,%s,%s,%d)\n", id, ans[1].c_str(), ans[0].c_str(), ans[2].c_str(), id+2);
                id++;
                printf("%d(j,_,_,%d)\n", id, f);
                f = id;
                id++;
                ans.clear();
            }
            else
            {
                ans.push_back(x);//???
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值