pat-甲-1004

1004 Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:ID K ID[1] ID[2] … ID[K],where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
The input ends with N being 0. That case must NOT be processed.
Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.
Sample Input:
2 1
01 1 02
Sample Output:
0 1

思路

  • 树的遍历
  • 为求每层的叶子数,可以用广度优先遍历
  • 每个节点的孩子数不确定,将多叉树转为二叉树
  • 统计每层叶子数,可以通过每个节点标记level,用数组记录每层的叶子数
  • 坑 :可能先出现孩子后出现父亲(测试点 1 ,3),需要先建树,后标记层。
  • 结构体,数组 初始化
  • 队列的使用
    • 出队列不能简单pop ,需要front获取队列首元素,再pop。pop无返回值
#include <iostream>
#include <stdio.h>
#include <queue>
using namespace std;
struct Node {
  int level;
  int child;
  int slid;
  Node(){
    level = 0;
    child = 0;
    slid = 0;
  }
};
int main(){
  int n,m,i,level,count,id,j,kid,last;//,maxl;
  queue<int> q;
  if( 2 != scanf("%d%d",&n,&m))
     return -2;
  Node tree[n+1];
  int counts[n+1]={0};
  // 初始化root
  level = 1;
  counts[1]=0;
  tree[1].level =1;
  tree[1].child = 0;
  tree[1].slid = 0;
// 建树,不能再此处对节点初始化,若父节点后出现,则会有覆盖子节点的情况
  for(i=0;i<m;i++){
    if( 3 != scanf("%d%d%d",&id,&count,&kid))
       return -2;
    tree[id].child = kid;
    last = kid;
    for(j=1;j<count;j++){
      if( 1 != scanf("%d",&kid))
         return -2;
      tree[last].slid = kid;
      last = kid;
    }
  }
  // 广度优先遍历
  q.push(1);
  level = 1;
  int index;
  while(!q.empty()){
     index = q.front();   //index = q.pop();
     q.pop();
     if(tree[index].child){
       level = tree[index].level+1;
       index = tree[index].child ;
       tree[index] .level = level;
       q.push(index);
        while(tree[index].slid){
          index = tree[index].slid;
           tree[index].level = level;
           q.push(index);
        }
     }else{
       counts[tree[index].level]++;
     }
  }
  printf("%d",counts[1]);
  for(i=2;i<level+1;i++)
    printf(" %d",counts[i]);
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值