1129. Recommendation System (25)

1129. Recommendation System (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (<= 50000), the total number of queries, and K (<= 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i = 1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:
12 3
3 5 7 5 5 3 2 1 8 3 8 12
Sample Output:
5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

题意:做一个简单的推荐系统。用户输入N个查询,对于每个查询,输出K的推荐。

推荐的规则:按查询次数由大到小输出,相等时,优先输出 数值 小的(即 3 5 次数相等时,先输出3再输出5)

思路:利用set自动排序的功能存储,由于需要记录两个参数(数值 和 次数),所以要重载<,以便排序

    由于排序时 需要用到插入、查找的操作,所以在struct 结构体内需要一个构造函数,便于插入、查找。

代码:

#include<iostream>
#include<set>
using namespace std;
struct node {
	int value;
	int cnt;
	node(int a, int b) :value(a), cnt(b) {}
	bool operator < (const node & a) const {
		return (cnt != a.cnt) ? cnt > a.cnt :value < a.value;
	}
};
int times[50010] = { 0 };
int main()
{
	int n, k, tmp;
	cin >> n >> k;
	set<node > num;
	for (int i = 0; i < n; i++)
	{
		cin >> tmp;
		if (i)
		{
			cout << tmp << ":";
			int j = 0;
			for (auto t = num.begin(); j < k && t != num.end(); t++, j++)
				cout << " " << t->value;
			cout << endl;
		}
		auto t = num.find(node(tmp, times[tmp]));
		if (t != num.end()) num.erase(t);
		times[tmp]++;
		num.insert(node(tmp, times[tmp]));
	}
}


结尾: 这题做的很有挫败感。先是题目半天读不懂,百度了以后发现排序很繁琐,再次百度以后知道了要用set,然后先前没有接触于是又是一通百度,实现的过程也是惨不忍睹……最后还是借助了柳婼小姐姐的代码   http://blog.csdn.net/liuchuo/article/details/68912867 




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值