1129 Recommendation System(25 分)

1129 Recommendation System(25 分)
Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user’s preference by the number of times that an item has been accessed by this user.

Input Specification:
Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing – for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:
For each case, process the queries one by one. Output the recommendations for each query in a line in the format:
query: rec[1] rec[2] … rec[K]
where query is the item that the user is accessing, and rec[i] (i=1, … K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:
12 3
3 5 7 5 5 3 2 1 8 3 8 12
Sample Output:
5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

题目大意:让你做一个推荐系统,用户会进行N次查询,每次查询一个数字,你要在用户每次查询之前(不包括第一次查询)给出用户已经查询过的,出现次数最高的K个数(也可能不足K个)。

分析:直接用一个vector保存出现频率最高的k个数,用map保存每个数出现的频率,每读入一个数就检查一次vector并更新,然后输出vector就可以了。

#include <cstdio>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;
int main(){
    int n,k,t;
    scanf("%d %d\n%d",&n,&k,&t);
    map<int,int> m;
    vector<int> result;
    result.resize(k);
    result[0]=t;
    m[t]++;
    for(int i=1;i<n;i++){
        scanf("%d",&t);
        printf("%d:",t);
        for(int i=0;i<k;i++){
            if(result[i]) printf(" %d",result[i]);
        }
        printf("\n");
        m[t]++;
        bool exist=false;    //exist表示t是否已经在result中
        for(int j=0;j<k;j++){
            if(result[j]==t){
                exist=true;
                while(j!=0&&(m[t]>m[result[j-1]]||m[t]==m[result[j-1]]&&t<result[j-1])){
                    swap(result[j],result[j-1]);
                    j--;
                }
                break;
            }
        }
        if(exist==false){
            if(m[t]>m[result.back()]||m[t]==m[result.back()]&&t<result.back()){
                for(int j=0;j<k;j++){
                    if(m[t]>m[result[j]]||m[t]==m[result[j]]&&t<result[j]){
                        result.insert(result.begin()+j,t);
                        result.pop_back();
                        break;
                    }
                }
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值