1126. Eulerian Path (25)

1126. Eulerian Path (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either "Eulerian", "Semi-Eulerian", or "Non-Eulerian". Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6
Sample Output 1:
2 4 4 4 4 4 2
Eulerian
Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6
Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian
Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3
Sample Output 3:
3 3 4 3 3
Non-Eulerian
分析:一道阅读理解题。简单讲就是 给一张图,如果图内所有顶点的度都是偶数,那么就是Eulerian;如果有且仅有两个是奇数,就是Semi-Eulerian;其他情况,就是Non-Eulerian。

注意:1.测试数据中有一组(好像是测试点3)是不连通的图,所以需要深搜一下图是否联通。

           2.这个点还会引出一个问题,比如我写的时候,是一边搜索一边算度。如果是不连通,那么没搜到的几个点的度就是默认的0,导致结果错误。

代码:

#include<iostream>
#include<algorithm> 
using namespace std;
int map[3000][3000]={0};
int visited[3000]={0};
int num[3000]={0};
int n,m,coun=0;
int get_number(int j){
  int num=0;
  for(int i=1;i<=n;i++)
    if(map[j][i]) num++;
  return num;
}
void dps(int j){
  coun++;
  visited[j]=1;
  for(int i=1;i<=n;i++)
    if(map[j][i] && !visited[i]) dps(i);
}
int main()
{
  int i,j,a,b,key=0;
  cin>>n>>m;
  for(i=0;i<m;i++)
  {
    cin>>a>>b;
    map[a][b]=1;
    map[b][a]=1;
  }
  dps(1);
  for(i=1;i<=n;i++)
  {
    num[i]=get_number(i);
    i==1?cout<<num[i]:cout<<" "<<num[i];
    if(num[i]%2) key++;//统计奇数个数 
  }
  cout<<endl;
  if(key==0 && coun==n) cout<<"Eulerian"<<endl;
  else if(key==2 && coun==n) cout<<"Semi-Eulerian"<<endl;
  else cout<<"Non-Eulerian"<<endl;
  return 0;
}

结尾:可以用vector做邻接表优化,这样就不用写代码数度了,直接size()就ok

vector<vector<int>> map;

vector<int > visited;






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值