HDU 6024 Building Shops 区间dp

Building Shops
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 701 Accepted Submission(s): 265

Problem Description
HDU’s n classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these n classrooms.

The total cost consists of two parts. Building a candy shop at classroom i would have some cost ci. For every classroom P without any candy shop, then the distance between P and the rightmost classroom with a candy shop on P’s left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.

Input
The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer n(1≤n≤3000), denoting the number of the classrooms.
In the following n lines, each line contains two integers xi,ci(−109≤xi,ci≤109), denoting the coordinate of the i-th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.

Output
For each test case, print a single line containing an integer, denoting the minimal cost.

Sample Input
3
1 2
2 3
3 4
4
1 7
3 1
5 10
6 1

Sample Output
5
11

题意:
有n个教室,现在想在这n个教室中建一些超市,问你最少费用为多少?
费用分为两种:
1:在第i个教室建超市,费用因为ci

2:没有建超市的教室的费用为它和它左边最接近的超市的坐标之间的距离

第一眼就觉得可以用区间dp来写,和之前写过的POJ - 1260换珍珠的区间dp很像

ps:计算diss的时候,没有用longlong,WA到怀疑人生QAQ

#include <cmath>
#include <stdio.h>
#include <cstring>
#include<iostream>
#include <algorithm>
using namespace std;
struct node { long long int x,c; }in[3005];
bool cmp(node n1,node n2) { return n1.x < n2.x; }
int main() {
    int n;
    long long int dis[3005],dp[3005];//x,c的范围都很大,所以用longlong
    while(scanf("%d",&n)!=EOF){
        memset(dp,0,sizeof(dp));
        memset(dis,0,sizeof(dis));
        for(int i=1;i<=n;i++) scanf("%lld%lld",&in[i].x,&in[i].c);
        sort(in+1,in+1+n,cmp);//这里必须排序,因为有可能乱序输入
        for(int i=1;i<=n;i++){
            dis[i]+=in[i].x-in[1].x;
            dis[i]+=dis[i-1];
            //cout<<dis[i]<<endl;
        }
        for(int i=n;i>1;i--){
            dp[i]=dp[i+1]+in[i].x-in[1].x;//第i个教室不建糖果屋的费用
            for(int j=i+1;j<=n+1;j++){//第i个教室建糖果屋
                long long int diss=0;
                diss=dis[j-1]-dis[i]-(j-1-i)*(in[i].x-in[1].x);//范围(i+1,j-1)内的教室到i的距离
                dp[i]=min(dp[i],dp[j]+diss+in[i].c);//取最小dp[j]是之前求出的最优解
            }
            //cout<<dp[i]<<endl;
        }
        dp[1]+=in[1].c;//第一个教室必定要建糖果屋
        dp[1]+=dp[2];
        printf("%lld\n",dp[1]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值