求众数Majority Element

求众数Majority Element

Problem description
Given an array of size n, find the majority element. The majority element is the element that appears more than ⌊ n/2 ⌋ times.
You may assume that the array is non-empty and the majority element always exist in the array.
The range of length of array is n(1≤n≤5,000,000) and the element (integer) in array is no bigger than 10,000,00000.
Input
Line 1: the length of array.
Line 2: the all elements in array and split by spaces
Output
Line 1: A single integer that is the majority element.
Sample Input 1
3
2 3 2
Sample Output 1
2
Sample Input 2
7
2 1 2 2 3 3 2
Sample Output 2
2

#include <iostream>
#include <vector>
using namespace std;
int main() {
    int a;
    cin>>a;
    int nums[a];
    for(int i=0;i<a;i++)
        cin>>nums[i];
     int flag=nums[0];
        int count=1;
        for(int i=1;i<a;i++){
            if(count==0){
                count ++;
                flag=nums[i];
            }else if(flag==nums[i]){
                count++;
            }else{
                count--;
            }
        }
 cout<<flag; 
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

a soldiers

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值