PAT 甲级 A1054

1071 Speech Patterns (25分)

题目描述

Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

输入格式

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,224​​). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

输出格式

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

总结

  1. 题目大概意思是让我们找出出现一半以上的像素,并每个输入样例都有。这题就很像某年408要求找出主元素的题。
  2. 思路很简单,就利用一个计数器和一个保存变量的数就行了,首先令答案为第一个数,并且计数器为1。若下一个数相同,计数器加一;反之则减一,当计数器小于0时,则令答案为新的数,并且计数器重置为1
  3. 另外一个解法是用map,实现起来更简单,不过要用额外的空间来存储,有点浪费空间。

AC代码

解法1

#include <iostream>
using namespace std;
int main() {
	int m, n, pixel, cnt = 0, ans;
	bool flag = true;
	scanf("%d %d", &m, &n);
	while(n--) {
		for (int j = 0; j < m; j++) {
			scanf("%d", &pixel);
			if (flag) {   //记录首位数字
				ans = pixel;
				flag = false;
			}
			if (cnt == pixel) {
				cnt++;
			}
			else {
				cnt--;
				if (cnt <= 0){
					ans = pixel;
					cnt = 1;
				} 
			}
		}
	}
	printf("%d\n", ans);
	return 0;
}

解法2

#include <iostream>
#include<unordered_map>
using namespace std;
int main() {
	int m, n, pixel, threshold;
	unordered_map<int, int> count;
	scanf("%d %d", &m, &n);
	threshold = m * n / 2;
	while(n--) {
		for (int i = 0; i < m; i++) {
			scanf("%d", &pixel);
			if (count.find(pixel) == count.end()) count[pixel] = 1;
			else count[pixel]++;
		}
	}
	for (auto it = count.begin(); it != count.end(); it++) {
		if (it->second > threshold) {
			printf("%d\n", it->first);
			break;
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值