[PAT A1054]The Dominant Color
题目描述
Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.
输入格式
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.
输出格式
For each test case, simply print the dominant color in a line.
输入样例
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
输出样例
24
解析
题目很简单,意思就是给出N*M的矩阵,要求N*M个数中超过半数的那个数,由于保证一定有解,我们甚至可以不需要判断是否存在这样的数。
#include<iostream>
#include<map>
using namespace std;
map<int, int>colors;
int main()
{
int m, n;
scanf("%d%d", &m, &n);
for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
int temp;
scanf("%d", &temp);
colors[temp]++;
}
}
int count = m * n;
for (map<int, int>::iterator it = colors.begin(); it != colors.end(); it++) {
if (it->second > m*n / 2) printf("%d",it->first);
}
return 0;
}