POJ_1611-The Suspects(并查集)

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1

      【题意】 有很多组学生,在同一个组的学生经常会接触,也会有新的同学的加入。但是SARS是很容易传染的,只要在改组有一位同学感染SARS,那么该组的所有同学都被认为得了SARS。现在的任务是计算出有多少位学生感染SARS了。假定编号为0的同学是得了SARS的。

   【分析】显然是并查集类的题,做法就是每次读入一组数,为同一个集合,同时如果与其他集合有共同元素,就与其他集合合并,最后找出含有0的集合的元素个数,即为所求。

   【代码】

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=30005;
int m,n,a[N];
int c[N],num[N];

int eluer(int n)
{
    if(n==a[n]) return a[n];
    else return eluer(a[n]);
}

void check(int x,int y)
{
    int aa=eluer(x);
    int bb=eluer(y);
    if(aa==bb) return ;
    a[aa]=bb;

    num[bb]+=num[aa];//不同根节点合并  总数相加   //顺序不能变
}

int main()
{
    int t;
    while(~scanf("%d%d",&m,&n))
    {
        if(m==0&&n==0)
            break;
        for(int i=0;i<m;i++)//这儿一定是从0开始的,不然最后结果数少1,因为0自己也是传染者
        {
            a[i]=i;
            num[i]=1;//不要标记为0,这方便最后计数
        }
        while(n--)
        {
            scanf("%d",&t);
            for(int i=0;i<t;i++)
                scanf("%d",&c[i]);
            for(int i=0;i<t-1;i++)
                check(c[i],c[i+1]);
        }
        printf("%d\n",num[eluer(0)]);//找0所在集合的根节点,输出此集合的总元素个数
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值