17暑假多校联赛7.5 HDU 6124 Euler theorem

Euler theorem

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 524288/524288 K (Java/Others)

Problem Description

HazelFan is given two positive integers a,b, and he wants to calculate amodb. But now he forgets the value of b and only remember the value of a, please tell him the number of different possible results.

Input

The first line contains a positive integer T(1≤T≤5), denoting the number of test cases.
For each test case:
A single line contains a positive integer a(1≤a≤109).

Output

For each test case:
A single line contains a nonnegative integer, denoting the answer.

Sample Input
2
1
3
Sample Output
2
3


题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=6124

分析

题意:给出一个正整数a,判断a对整数取模之后会有几种值
很水的题,能发现小于a的一半的数都有可能,加上a本身,不管奇数偶数加上1再除以2的话就把a/2也包含了,再加上a本身,直接输入输出就行了

代码
#include<bits/stdc++.h>
using namespace std;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        printf("%d\n",((n+1)/2)+1);
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值