33. Treats for the Cows

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:

  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.

Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N.

Lines 2..N+1: Line i+1 contains the value of treat v(i).

Output

Line 1: The maximum revenue FJ can achieve by selling the treats.

Sample Input

5
1
3
1
5
2

Sample Output

43

Hint

Explanation of the sample :

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.


测试输入关于“测试输入”的帮助期待的输出关于“期待的输出”的帮助时间限制关于“时间限制”的帮助内存限制关于“内存限制”的帮助额外进程关于“{$a} 个额外进程”的帮助
测试用例 1以文本方式显示
  1. 5↵
  2. 1↵
  3. 3↵
  4. 1↵
  5. 5↵
  6. 2↵
以文本方式显示
  1. 43↵
1秒64M0



//设Num_dp[i][j]为i-j这一段的最大价值
//Num_dp[i][j]=max(dp[i+1][j]+Num_Str[i]*pp, Num_dp[i][j-1]+Num_Str[j]*pp)
//其中pp为第pp次拿,pp=n-(j-i)
#include<stdio.h>

int Num_N, Num_dp[2005][2005] = { 0 }, Num_Str[2005] = { 0 };
int fMax(int a, int b)
{
	return (a > b ? a : b);
}
int main()
{
	scanf("%d", &Num_N);
	for (int i = 1; i <= Num_N; i++)
		scanf("%d", &Num_Str[i]);
	for (int i = Num_N; i >= 1; i--)
		for (int j = i; j <= Num_N; j++)
		{
			int pp = Num_N - (j - i);
			Num_dp[i][j] = fMax(Num_dp[i+1][j] + pp*Num_Str[i], Num_dp[i][j-1] + pp*Num_Str[j]);
		}
	printf("%d\n", Num_dp[1][Num_N]);

	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值