PAT A1057. Stack (30)

1057. Stack (30)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 105). Then N lines follow, each contains a command in one of the following 3 formats:

Push  key
Pop
PeekMedian

where key is a positive integer no more than 105.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print "Invalid" instead.

Sample Input:
17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop
Sample Output:
Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid
思路分析:

用一个栈模拟实现栈的输入输出即可,关键在于如何查询中值。可以利用分块思想处理,先确定待查询的数在哪一块儿,再在块儿内进行查询即可。

题解:

#include <cstdio>
#include <stack>
#include <cstring>
using namespace std;
const int MAX = 100001;
const int MAXN = 317;
int n, block[MAXN] = {0}, table[MAX] = {0};
char order[11];
stack<int> s;

bool cmp(int a, int b){
	return a < b;
}

int main(){
	scanf("%d", &n);
	while(n--){
		scanf("%s", order);
		if(strcmp(order, "Pop") == 0){
			if(!s.empty()){
				int k = s.top();
				printf("%d\n", k);
				s.pop();
				block[k/(MAXN-1)]--;
				table[k]--;
			}else printf("Invalid\n");
		}else if(strcmp(order, "PeekMedian") == 0){
			if(s.empty()){
				printf("Invalid\n");
				continue;
			}
			int k, idx = 0, index = 0;
			if(s.size() % 2 == 0) k = s.size()/2;
			else k = (s.size()+1)/2;
			int sum = 0;
			while(sum + block[idx] < k){
				sum += block[idx++];
			}
			index = idx * (MAXN-1);
			while(sum + table[index] < k){
				sum += table[index++];
			}
			printf("%d\n", index);
		}else{
			int k;
			scanf("%d", &k); 
			s.push(k);
			table[k]++;
			block[k/(MAXN-1)]++;
		}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值