HDU 1010 Tempter of the Bone

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

 

 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

 

 

Sample Input

4 4 5

S.X.

..X.

..XD

....

3 4 5

S.X.

..X.

...D

0 0 0

 

 

Sample Output

NO

YES

 

 

Author

ZHANG, Zheng

 

思考:这个题目是最初学深搜的时候遇到的。是很经典的搜索,如果有一条路,刚好在T秒时候到达,那就是对的,如果没有这样的一条路,那就是失败的。1年前的代码

#include<stdio.h>
#include<math.h>
#include<algorithm>

using namespace std;

char book[9][9];
int n, m, t, sx, dx, sy, dy, ok;
int nxt[4][2]={{0,1},{0,-1},{1,0},{-1,0}};

int main()

 void dfs(int sx,int sy,int deep); 
    int i, j, k;
    while(scanf("%d%d%d", &n, &m, &t) != EOF)
    {
        getchar(); 
        if(n == 0 && m == 0 && t == 0)
            break;
        for(i = 1, k = 0; i <= n; i++)
        {
            for(j = 1; j <= m; j++)
            {
                scanf("%c", &book[i][j]);
                if(book[i][j] == 'S') 
                {
                    sx = i;
                    sy = j; 
                }
                if(book[i][j] == 'D')
                {
                    dx = i;
                    dy = j;
                }
                if(book[i][j] == 'X')
                    k++;    
            }
            getchar();
        }
        if(n*m-k < t)    //如果你走完所有可以走的地方,还有剩余的时间,那么是肯定不能活下来的。 
           printf("NO\n");
        else
        {
            ok = 0;
            book[sx][sy] = 'X'; 
            dfs(sx, sy, 0);
            if(ok == 1)
                printf("YES\n");
            else    
                printf("NO\n");
        }
    }
    return 0;
}
void dfs(int sx, int sy, int deep)
{
    int i, ans;
    if(sx == dx && sy == dy && deep == t) ok=1;//如果在t秒的时候刚刚走到,那么就是对的。 
    if(ok) return;
    if(sx < 1 || sy < 1 || sx > n || sy > m) return;   //迷宫边界处理 
    ans = t - deep - abs(dx - sx) - abs(dy - sy);  
    if(ans < 0 || ans & 1) return;  //如果剩下的每一步都走对的话,不能刚好到达,说明之前走的路不对 
    for(i = 0; i < 4; i++)
    {  int tx = sx + nxt[i][0];
        int ty = sy + nxt[i][1];
        if(book[tx][ty] != 'X') 
        {
            book[tx][ty] = 'X';  //走过的路标记为墙 
            dfs(tx, ty, deep+1);
            book[tx][ty] = '.';
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值