HDU-6225-Little Boxes(4个大数相加,模板题)

26 篇文章 0 订阅

Little Boxes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 4083    Accepted Submission(s): 1549


 

Problem Description

Little boxes on the hillside.
Little boxes made of ticky-tacky.
Little boxes.
Little boxes.
Little boxes all the same.
There are a green boxes, and b pink boxes.
And c blue boxes and d yellow boxes.
And they are all made out of ticky-tacky.
And they all look just the same.

 

 

Input

The input has several test cases. The first line contains the integer t (1 ≤ t ≤ 10) which is the total number of test cases.
For each test case, a line contains four non-negative integers a, b, c and d where a, b, c, d ≤ 2^62, indicating the numbers of green boxes, pink boxes, blue boxes and yellow boxes.

 

 

Output

For each test case, output a line with the total number of boxes.

 

 

Sample Input

 

4 1 2 3 4 0 0 0 0 1 0 0 0 111 222 333 404

 

 

Sample Output

 

10 0 1 1070

 

 

Source

2017ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学)

 

 

Recommend

jiangzijing2015   |   We have carefully selected several similar problems for you:  6447 6446 6445 6444 6443 

 

看下sample就知道是个模板题啦~~(看来可以先看样例猜下题意哈哈)模板来自博客链接

【通过代码】 

# include<cstdio>
# include<cstring>
# include<cstdlib>
#include<iostream>
#define mem(a) memset(a,0,sizeof(a))
using namespace std;
void add(char* a,char* b,char* c)//模板
{
    int i,j,k,max,min,temp;
    char *s,*pmax,*pmin;
    max=strlen(a);
    min=strlen(b);
    if (max<min)
    {
        temp=max;
        max=min;
        min=temp;
        pmax=b;
        pmin=a;
    }
    else
    {
        pmax=a;
        pmin=b;
    }
    s=(char*)malloc(sizeof(char)*(max+1));
    s[0]='0';
    for (i=min-1,j=max-1,k=max;i>=0;i--,j--,k--)
        s[k]=pmin[i]-'0'+pmax[j];
    for (;j>=0;j--,k--)
        s[k]=pmax[j];
    for (i=max;i>=0;i--)
        if (s[i]>'9')
        {
            s[i]-=10;
            s[i-1]++;
        }
    if (s[0]=='0')
    {
        for (i=0;i<=max;i++)
            c[i-1]=s[i];
        c[i-1]='\0';
    }
    else
    {
        for (i=0;i<=max;i++)
            c[i]=s[i];
        c[i]='\0';
    }
    free(s);
}
char a[50],b[50],c[50],d[50],ans[50];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>a>>b>>c>>d;
        mem(ans);
        add(a,b,ans);
        add(c,ans,ans);
        add(d,ans,ans);
        puts(ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值