PAT A1020【Tree Traversals】(25 分)

1020 Tree Traversals (25 分)

题目链接

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output

4 1 6 3 5 7 2

中规中矩的一道题,根据中序和后序构建树,然后进行层次遍历:

#include<iostream>
#include<queue>
using namespace std;

//https://pintia.cn/problem-sets/994805342720868352/problems/994805485033603072

const int maxn = 32;
int postorder[maxn];
int inorder[maxn];

struct Node{
	int data;
	Node *lchild, *rchild;
};

Node *create_tree(int inL, int inR, int postL, int postR)
{
	if(inL > inR)
		return NULL;
	Node *root = new Node;
	root->data = postorder[postR]
	int k;
	for(k=inL; k<=inR; k++){
		if(inorder[k] == postorder[postR])
			break;
	}
	int numLeft = k-inL;
	root->lchild = create_tree(inL, k-1, postL, postL+numLeft-1);
	root->rchild = create_tree(k+1, inR, postL+numLeft, postR-1);
	return root;
}

void layerorder(Node *root)
{
	queue<Node*> q;
	q.push(root);
	bool space_flag = false;
	while(!q.empty()){
		Node *node = q.front();
		q.pop();
		if(space_flag)
			cout<<" ";
		space_flag = true;
		cout<<node->data;
		if(node->lchild)
			q.push(node->lchild);
		if(node->rchild)
			q.push(node->rchild);
	}
}

void in(Node *root)
{
	if(root == NULL)
		return;
	in(root->lchild);
	cout<<root->data<<" ";
	in(root->rchild);
}

int main()
{
	int N;
	cin>>N;
	for(int i=1; i<=N; i++)
		cin>>postorder[i];
	for(int i=1; i<=N; i++)
		cin>>inorder[i];
	Node *root = create_tree(1, N, 1, N);
	layerorder(root);
	return 0;
 } 

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值