(搜索)POJ-1979 Red and Black

11 篇文章 0 订阅
6 篇文章 0 订阅

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13


代码:

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
typedef struct nod
{
    int x;
    int y;
    struct nod *next;
} Qnode,*QueuePtr,no,mo;
typedef struct
{
    QueuePtr front1;
    QueuePtr rear;
} LinkQueue;
char a[31][31];
int vis[31][31];
int dx[4]= {-1,0,1,0};
int dy[4]= {0,1,0,-1};
int initQueue(LinkQueue &Q)
{
    Q.front1=Q.rear=(Qnode *)malloc(sizeof(Qnode));
    Q.front1->next=0;
    return 0;
}
int EnQueue(LinkQueue &Q,no &e)
{
    Qnode *p;
    p=(Qnode *)malloc(sizeof(Qnode));
    p->x=e.x;
    p->y=e.y;
    p->next=0;
    Q.rear->next=p;
    Q.rear=p;
    return 0;
}
no DeQueue(LinkQueue &Q,no &e)
{
    Qnode *p;
    p=Q.front1->next;
    e.x=p->x;
    e.y=p->y;
    Q.front1->next=p->next;
    if(Q.rear==p)
        Q.rear=Q.front1;
    return e;
}
int Empty(LinkQueue &Q)
{
    if(Q.rear==Q.front1)
        return 1;
    return 0;
}
int main()
{
    int n,m;
    int i,j;
   // freopen("C:\\Users\\Administrator\\Desktop\\114.txt","r",stdin);
    while(~scanf("%d%d",&n,&m))
    {
        LinkQueue Q;
        int num=0;
        no e;
        mo e1;
        memset(vis,0,sizeof(vis));
        int k1=-1,k2=-1;
        if(n==0&&m==0)
            break;
        for(i=0; i<m; i++)
        {
            for(j=0; j<n; j++)
            {
                cin>>a[i][j];
                if(a[i][j]=='@')
                {
                    k1=i;
                    k2=j;
                }
                else if(a[i][j]=='.')
                {
                    vis[i][j]=1;
                }
            }
        }
        initQueue(Q);
        e.x=k1;
        e.y=k2;
        EnQueue(Q,e);
        while(!Empty(Q))
        {

            e=DeQueue(Q,e);
            for(i=0; i<4; i++)
            {

                e1.x=e.x+dx[i];
                e1.y=e.y+dy[i];
                if(e1.x>=0&&e1.x<m&&e1.y>=0&&e1.y<n&&vis[e1.x][e1.y]==1)
                {
                    vis[e1.x][e1.y]=0;
                    num++;
                    EnQueue(Q,e1);
                }
            }

        }
        cout<<num+1<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值