The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
InputThe input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.
The input is terminated with three 0's. This test case is not to be processed.
OutputFor each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
Sample Input
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0Sample Output
NO YES
#include<stdio.h>
#include<string.h>
#include<cmath>
#include<iostream>
using namespace std;
int n,m,t;
int f,t1;
int nn=0;
int r1,r2;
char a[25][25];
int vis[25][25];//标记数组
int dx[4]= {1,0,-1,0};
int dy[4]= {0,1,0,-1};
int sum;
int dfs(int i,int j,int sum)
{
if(sum==t)
{
if(a[i][j]=='D')
f=1;//标记成功到达终点,为退出递归做准备。
return 0;
}
for(int r=0; r<4; r++)
{
int nx=i+dx[r];
int ny=j+dy[r];
if(nx>=0&&ny>=0&&nx<n&&ny<m&&!vis[nx][ny]&&sum<t)//判断是否到迷宫边界且没走过的点
{
vis[nx][ny]=1;//走过则标记为1
dfs(nx,ny,sum+1);
vis[nx][ny]=0;退回来则重置为0
if(f||(sum>=t))return 0;//到达终点后或者步数大于t则不必再搜索,退回递归上一步。
}
}
return 0;
}
int main()
{
while(~scanf("%d%d%d",&n,&m,&t))
{
if(!n|!m|!t)
break;
f=0;
int i,j;
sum=0;
int k1=0,k2=0;
memset(vis,0,sizeof(vis));
r1=0,r2=0;
int num=0;
for(i=0; i<n; i++)
for(j=0; j<m; j++)
{
cin>>a[i][j];
if(a[i][j]=='S')
{
k1=i;
k2=j;
vis[i][j]=1;
}
else if(a[i][j]=='X')
{
vis[i][j]=1;
num++;
}
else if(a[i][j]=='D')
{
r1=i;
r2=j;
}
}
t1=0;
t1=t&1;
if(n*m-num-1<t)//判断墙的的个数是否比总共的点数与恰好走的步数之差大
{
printf("NO\n");
continue;
}
int minn=abs(r1-k1)+abs(r2-k2);//起点与终点的最短距离
if(t1==(minn&1))//只有步数t的奇偶性与起点与终点的最短距离的奇偶性相同,才有成功的可能
{
dfs(k1,k2,0);
if(f)
{
printf("YES\n");
}
else
{
printf("NO\n");
}
}
else
{
printf("NO\n");
}
}
return 0;
}