POJ1458 Common Subsequence 最长公共子序列 公共子串

 

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

 

题意:最长公共子序列(LCS)问题:给定两个序列X=<x1,x2,……,xn>和Y=<y1,y2,……,yn>,求X和Y长度最长的公共子序列。

动态规划方法求解,dp[i][j]:=x1···xi和y1···yj对应的LCS长度。

 

设Z=<z1,z2……,zk>为x1···xi+1和y1···yj+1的LCS,Z可能为:

  • 若xi+1=yj+1,x1···xi和y1···yj的LCS末尾加上xi+1;
  • x1···xi和y1···yj+1的LCS。
  • x1···xi+1和y1···yj的LCS。

由此可以得到递归关系式:

利用该数组通过回溯可以得到最长公共子序列

 

#include<iostream>
#include<cstring>
#include<string>
using namespace std;
int dp[2][1000];//利用滚动数组减小内存
int main()
{
	string a,b;
	int m,n;
	while(cin>>a>>b)
	{
		memset(dp,0,sizeof(dp));
		m=a.length(),n=b.length();
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
			{
				if(a[i]==b[j])
					dp[(i+1)&1][j+1]=dp[i&1][j]+1;
				else
					dp[(i+1)&1][j+1]=max(dp[i&1][j+1],dp[(i+1)&1][j]);
			}
		cout<<dp[m&1][n]<<endl;
	}
	return 0;
}

最长公共子串:

数组c[i,j]记录结尾同时为Xi和Yj的子串长度,状态转移方程

取数组最大值即为最长公共子串的长度。

 

#include<iostream>  
#include<string>  
#include<cstring>  
using namespace std;
const int maxn = 100;
int dp[maxn][maxn] = { 0 };

int lcs(string str1, string str2)
{
	memset(dp, 0, sizeof(dp));
	int result = 0;
	for (int i = 1; i <= str1.length(); i++)
	{
		for (int j = 1; j <= str2.length(); j++)
		{
			if (str1[i - 1] == str2[j - 1])
			{
				dp[i][j] = dp[i - 1][j - 1] + 1;
				result = max(result, dp[i][j]);
			}
		}
	}
	return result;
}

int main()
{
	string str1,str2;
	cin >> str1 >> str2;
	int res = lcs(str1, str2);
	cout << res << endl;
	return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值