POJ 3468 A Simple Problem with Integers

A Simple Problem with Integers

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 147870 Accepted: 45935
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

POJ Monthly--2007.11.25, Yang Yi

 

#include<iostream>
#include<string.h>
#include<stdio.h>
#define inf 0x3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1  
#define IOS ios_base::sync_with_stdio(false),cin.tie(0),cout.tie(0)		
using namespace std;
typedef long long ll;
const int _max = 111111;
ll sum[_max<<2],lazy[_max<<2];
void PushUp(int rt){
	sum[rt] = sum[rt<<1]+sum[rt<<1|1];
	return ;
}
void PushDown(int rt,int m){
	if(lazy[rt]){
		lazy[rt<<1] += lazy[rt];
		lazy[rt<<1|1] += lazy[rt];
		sum[rt<<1] += lazy[rt]*(m-(m>>1));
		sum[rt<<1|1] += lazy[rt]*(m>>1);
		lazy[rt] = 0; 
	}
}
void build(int l,int r,int rt){
	lazy[rt] = 0;
	if(l == r){
		scanf("%lld",&sum[rt]);
		return ;
	}
	int m =(l+r)>>1;
	build(lson);
	build(rson);
	PushUp(rt);
	return ;
}
ll query(int L,int R,int l,int r,int rt){
	if(L <= l && r <= R)	return sum[rt];
	PushDown(rt,r-l+1);
	int m = (l+r)>>1;
	ll ret = 0;
	if(L <= m) ret += query(L,R,lson);
	if(R > m) ret += query(L,R,rson);
	return ret;
}
void updata(int L,int R,int np,int l,int r,int rt){
	if(L <= l && r <= R){
		lazy[rt] += np;
		sum[rt] += (r-l+1)*(ll)np;
		return ;
	}
	PushDown(rt,r-l+1);
	int m = (l+r)>>1;
	if(L <= m) updata(L,R,np,lson);
	if(R > m) updata(L,R,np,rson);
	PushUp(rt);
	return ;
} 
int main(){
	int n,q;
	scanf("%d%d",&n,&q);
	build(1,n,1);
	while(q--){
		char op[2];
		int a,b,c;
		scanf("%s",op);
		if(op[0] == 'Q'){
			scanf("%d%d",&a,&b);
			printf("%lld\n",query(a,b,1,n,1));
		} 
		else{
			scanf("%d%d%d",&a,&b,&c);
			updata(a,b,c,1,n,1);
		}
	}			
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值