PAT 甲级 1005 Spell It Right

PAT 甲级 1005 Spell It Right

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345
结尾无空行

Sample Output:

one five
结尾无空行
题意描述:

给你一个N位数字,将每一位数字进行累加求和,然后将sum的每一位数字按照对应的英文输出。

解题思路:

纯模拟题。先吃进一个字符串,累加求和。对sum进行位数的拆分,并按照事先初始化的“数字-英文”的下标映射数组进行输出即可。

难度评测:Easy
AC代码实现:
#include <bits/stdc++.h>
using namespace std;

int main()
{
	string digit[10] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
	vector<string>ans;
	string n;
	cin >> n;
	int sum = 0;
	for(auto ch : n)
		sum += (ch - '0');
	if(sum == 0) {
		printf("zero");
		exit(0);
	}
	while(sum) {
		ans.push_back(digit[sum % 10]);
		sum /= 10;
	}
	reverse(ans.begin(), ans.end());
	cout << ans[0];
	for(int i = 1; i < ans.size(); i++)
		cout << " " << ans[i];
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值