PAT 甲级 1014 Waiting in Line

PAT 甲级 1014 Waiting in Line

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customeri will take T**i minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, custome**r1 is served at window1 while custome**r2 is served at window2. Custome**r3 will wait in front of window1 and custome**r4 will wait in front of window2. Custome**r5 will wait behind the yellow line.

At 08:01, custome**r1 is done and custome**r5 enters the line in front of window1 since that line seems shorter now. Custome**r2 will leave at 08:02, custome**r4 at 08:06, custome**r3 at 08:07, and finally custome**r5 at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry
题意描述:

银行有n个窗口,每个窗口仅限m个人同时排队,剩下的人需要站在黄线外等待,当所有队列已满的时候,下一位顾客需要等待某一队列中有人结束后才可以加入其所在的队列排队。每个人编号1-n,有q个询问,每次询问给出一个编号x,问你编号为x的人的结束时间是多少。需要注意17:00以后才开始办理业务的人输出Sorry。

解题思路:

这是一道模拟多窗口排队的应用题。本题的实现较为复杂,是难度较大的模拟题。

首先需要根据题意以及所给样例,理清楚本题排队的规则:

1、当队列还没满的时候,按顺序在窗口前排好。

2、当所有队列已满的时候,下一位顾客需要等待某一队列中有人结束后才可以加入其所在的队列排队,因此需要比较当前所有队列中处于队首的顾客的结束时间,求得最早结束的顾客及其窗口编号,然后将下一位顾客压入该队列中。

难度评测:Middle Hard
AC代码实现:
#include <bits/stdc++.h>
using namespace std;
const int N = 1e3+5;

int main() {
	int n, m, k, q, x, a[N], T[N];//T:每位顾客的结束时间 
	int End[25] = {0};//每个窗口当前的结束时间 
	queue<int>Q[25];//用队列存储每个窗口排队的顾客 
	cin >> n >> m >> k >> q;
	for(int i = 1; i <= k; i++) 
		cin >> a[i];
	int cur = min(k, n * m);//比较k与n*m的大小,判断k个人能否将队列塞满
	memset(T, -1, sizeof(T));//将T数组初始化为-1,表示还未办理业务 
	for(int i = 1; i <= cur; i++) { //前cur位顾客采用规则1排队 
		int id = i % n;//求得第i位顾客排队的窗口编号(0~n-1) 
		if(End[id] >= 540) {//若银行已经下班 
			continue;
		}
		T[i] = End[id] + a[i];//求得第i位顾客的结束时间 
		End[id] = T[i];//窗口id的结束时间更改为第i位顾客的结束时间 
		Q[id].push(i);
	}
	for(int i = cur + 1; i <= k; i++) {//若k>n*m,则需要采用规则2排队 
		int first = T[Q[0].front()], id = 0;
		for(int j = 1; j < n; j++) {//求得n个窗口中队首顾客最早结束的那个窗口编号 
			if(T[Q[j].front()] < first) { 
				first = T[Q[j].front()];
				id = j;
			}
		} 
		if(End[id] >= 540) {//若银行已经下班 
			continue;
		}
		T[i] = End[id] + a[i];//求得第i位顾客的结束时间 
		End[id] = T[i];//窗口id的结束时间更改为第i位顾客的结束时间 
		Q[id].pop();//将队首的顾客从队列中删除 
		Q[id].push(i);//将第i位顾客加入队列 
	} 
	while(q--) {
		cin >> x;
		if(T[x] == -1) {
			puts("Sorry");
		} 
		else {
			int h = T[x] / 60;
			int m = T[x] % 60;
			printf("%02d:%02d\n", h + 8, m);
		}
	}
} 
/*
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7 
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值