PAT 甲级 1015 Reversible Primes

PAT 甲级 1015 Reversible Primes

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2
结尾无空行

Sample Output:

Yes
Yes
No
结尾无空行
题意描述:

给你一个十进制数N,然后将N转换到D进制再翻转,将反转后的数字重新转换到十进制数M,问N和M是否都是素数。

解题思路:

根据题意模拟即可。本题主要考查的就是进制转换以及素数判断,都是比较基础的知识点。

难度评测:Normal
AC代码实现:
#include <bits/stdc++.h>
using namespace std;
#define CLR(arr, val) memset(arr, val, sizeof(arr))
const int N = 1e5+5;
int p[N], cnt = 0;
bool vis[N];

void Eular() {
	CLR(vis, false);
	vis[0] = vis[1] = true;
	for(int i = 2; i < N; i++) {
		if(!vis[i])	p[cnt++] = i;
		for(int j = 0; j < cnt && i * p[j] < N; j++) {
			vis[i * p[j]] = true;
			if(i % p[j] == 0)	break;
		} 
	}
}
int main() {
	Eular();
	int n, d;
	while(cin >> n && n >= 0) {
		cin >> d;
		vector<int>a;
		int x = n;
		while(n) {
			a.push_back(n % d);
			n /= d;
		}
		int y = 0;
		for(auto v : a)
			y = y * d + v;
		if(!vis[x] && !vis[y]) {
			puts("Yes");
		}
		else {
			puts("No");
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值