HDU1072 Nightmare BFS+剪枝

1 篇文章 0 订阅

问题描述:

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13073    Accepted Submission(s): 6383


Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
 
 
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
 
 
4 -1 13
题目大意:

在迷宫里有个定时炸弹,求能否在炸弹爆炸前逃出迷宫,若能够逃出迷宫,求最短时间。

问题分析:由题目可知,可以重复走已经走过的路,但是要注意的是时间重置装置只可能走一次,因为你每次走到这都能使时间重置为6,那么重置一次跟重置两次没有区别,所以只需要走一次即可,所以只需要标记时间重置装置所在地即可。

代码实现:

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
struct node{
	int x,y,t,T;
};

int mp[10][10],vis[10][10];
int d[4][2] = {1,0,-1,0,0,1,0,-1};
int T,n,m,Mint;

bool isOk(int x,int y)
{
	if (x<0||x>=n||y<0||y>=m||mp[x][y]==0||vis[x][y])
		return false;
	return true;
}
void bfs(int sx,int sy,int ex,int ey)
{
	queue<node>q;
	struct node now,next;
	now.x = sx;
	now.y = sy;
	now.t = 6;
	now.T = 0;
	q.push(now);
	while(!q.empty())
	{
		now = q.front();
		q.pop();
		if(now.t>=1&&now.x==ex&&now.y==ey)
		{
			Mint = min(Mint,now.T);
		}
		if(mp[now.x][now.y]==4)	vis[now.x][now.y] = 1;
		for(int i = 0; i < 4; i++)
		{
			next = now;
			next.x += d[i][0];
			next.y += d[i][1];
			if(isOk(next.x,next.y))
			{
				if(next.t==1)	continue;
				if(mp[next.x][next.y]==4)
				{
					next.t = 6;
				}
				else next.t--;
				next.T++;
				q.push(next);
			}
		}
	}
	return;
}
int main()
{
	int i,j,sx,sy,ex,ey;
	cin>>T;
	while(T--)
	{
		scanf("%d %d",&n,&m);
		for(i = 0; i < n; i++)
		{
			for(j = 0; j < m; j++)
			{
				scanf("%d",&mp[i][j]);
				if(mp[i][j]==2)
				{
					sx = i;
					sy = j;
				} 
				if(mp[i][j]==3)
				{
					ex = i;
					ey = j;
				}
			}
		}
		memset(vis,0,sizeof(vis));
		Mint = inf;
		vis[sx][sy] = 1;
		bfs(sx,sy,ex,ey);
		if(Mint != inf)	printf("%d\n",Mint);
		else			printf("-1\n");
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值