1021 Deepest Root@PTA

A graph which is connected and acyclic can be considered a tree. The hight of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

题目分析:

并查集找到连通分量的个数。

搜索找到每个点作为根时的深度。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <vector>
#include <set>
#include <stack>
#include <iomanip>
#include <cstdlib>
#include <queue>

using namespace std;

int n;
int vis[10003];
vector<int> point[10003];
int height[10003];

int f[10003];

int DFS(int node){
	int ans = 1;
	int len = point[node].size();
	for(int i=0;i<len;++i){
		if(!vis[point[node][i]]){
			vis[point[node][i]] = 1;
			int h = DFS(point[node][i]);
			if(h + 1 > ans) ans = h+1;
		}
	}
	return ans;
}

int getf(int a){
	int x = a;
	while(x != f[x]) x = f[x];
	while(f[a] != x){
		int j = f[a];
		f[a] = x;
		a = j;
	}
	return x;
}

void Union(int a,int b){
	int fa = getf(a);
	int fb = getf(b);
	if(fa != fb) f[fb] = fa;
}

int main(){
	cin >> n;
	for(int i=1;i<=n;++i){
		height[i] = 1;
		f[i] = i;
	}
	int a,b;
	for(int i=0;i<n-1;++i){
		cin >> a >> b;
		Union(a,b);
		point[a].push_back(b);
		point[b].push_back(a);
	}
	int coms = 0;
	for(int i=1;i<=n;++i){ //找到连通分量的个数
		if(f[i] == i) ++coms;
	}
	if(coms > 1){
		printf("Error: %d components\n",coms);
	}
	else{
		vector<int> vec;
		int max = 0;
		for(int i=1;i<=n;++i){ //对每个点进行搜索
			memset(vis,0,sizeof(vis));
			vis[i] = 1;
			height[i] = DFS(i);
			// cout << i << " : " << height[i] << endl;
			if(height[i] > max){
				max = height[i];
				vec.clear();
				vec.push_back(i);
			}
			else if(height[i] == max){
				vec.push_back(i);
			}
		}
		int len = vec.size();
		for(int i=0;i<len;++i) cout << vec[i] << endl;
	}
	return 0; 
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值