【HDU-1213】How Many Tables


点击打开链接


How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32574    Accepted Submission(s): 16254


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
  
  
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
  
  
2 4




//         题意: 分配桌子的问题,如果A认识B,B认识C,则ABC在一个桌子,D认识E,DE在另一个;
//        并查集: 认识的合并,看有几个根节点即安排几个桌子; 
//代码如下: 

#include <cstdio>
const int maxn = 1e6 + 10;
int par[maxn];
int ans = 0;
void init (int n)           //父亲节点赋值为与其本身相同的值 
{
	for (int i = 1; i <= n ;i++)
	  par[i] = i;
}
int find(int x)   //查找父亲节点 
{
	int p = x;
	while (x != par[x])
	  {
	  	 x = par[x];
	  }
    while (p != x)
      {
      	int j = par[x];
      	par[x] = x;
      	p = j;
	  }
return x;
}
void unite(int a,int b)  //合并 
{
	int fa = find(a);
	int fb = find(b);
	if (fa != fb)
	 {
	 	 par[fa] = fb;
	 }
}
int main()
{
	int t;
	scanf ("%d",&t);
	while (t--)
	 {
	 	int n,m;
	 	int a,b;
	 	ans = 0;
	 	scanf ("%d%d",&n,&m);
	 	init(n);
	 	for (int i = 0 ; i < m ; i++)
	 	 {
	 	 	scanf ("%d%d",&a,&b);
	 	 	unite(a,b);
		  }
		for (int i = 1 ; i <= n ; i++)
		 {
		 	if (par[i] == i)         //有几个根节点,就是答案。 
		 	   ans++; 
		 }
        printf ("%d\n",ans);
	 }
return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值