PAT 甲级 1001

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

第一题比较简单,主要是每三个数字输出用逗号分开。由于事先并不知道数字的位数,所以采用递归是容易想到的方案,当最后<1000是exit出来,但是注意字符串的添加是从前面添加的。采用c++中的string 类可以简单的看作+-运算。

但是,重点来了。当某三位是有0在前面,eg:1,002。002递归中由于采用的是to_string(int a)所以002 自然被翻译成2 ,怎么解决这个问题呢?

刚开始我想的是sprintf的方法,因为("%03d") 可以很简单的解决它,但是很遗憾,sprintf 只能对char[]数组类型进行操作,而本文的思路是由string 展开的,所以弃之。

本文采用了一个笨办法,就是else if来解决所以情况,因为最大只有3位数字,所以枚举所以情况也不是难事。





#include<stdio.h>

#include<string>
#include<iostream>
using namespace std;
void printSTD(int a,std::string ans)
{
    if(a<1000 && a>-1000) {
        ans=to_string(a)+ans;
        cout<<ans;
    }
    else{
        string tempstr=to_string(a%1000);
        if(tempstr.size()==2)
            tempstr='0'+tempstr;
        else if(tempstr.size()==1)
            tempstr="00"+tempstr;
        ans=","+tempstr+ans;
        printSTD(a/1000,ans);
    }
}

int main()
{
    int a,b;
    string ans="";
    scanf("%d %d",&a,&b);
    if(a+b<0){
        printf("-");
        printSTD(-(a+b),ans);
    }
    else printSTD(a+b,ans);
    return 0;    
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值