【PAT】1140 Look-and-say Sequence 最后一个测试点超时问题

1140 Look-and-say Sequence

Look-and-say sequence is a sequence of integers as the following:
D, D1, D111, D113, D11231, D112213111, …
where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (<=40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

思想:就是暴力枚举,这个没有啥思维就是考察编码水平。最后一个测试点我一开始居然超时了,后来发现下面两条语句含义是一样,但是效率却不同,使用上面一条语句进行字符串累加时,最后一个测试点就超时了,但是使用下面一条语句测试点却没有超时。现在还不知道原理是啥,希望找到原理的小伙伴能够给我个链接。

D_temp = D_temp + temp + to_string(sum);
D_temp += temp + to_string(sum);

具体原因: https://stackoverflow.com/questions/34465848/operator-in-c
超时代码:

#include<bits/stdc++.h>
using namespace std;
int main() {
	string D,D_temp=""; int N;
 	cin >> D; scanf("%d", &N);
	for (int i = 0; i < N-1; i++) {
		//string D_temp;
		int sum = 1; char temp = D[0];
		int len = D.length();
		for (int j = 1; j < len; j++) {
			if (temp == D[j]) sum++;
			else{
				D_temp = D_temp + temp + to_string(sum);
				temp = D[j];
				sum = 1;
			}
		}
		D_temp = D_temp + temp + to_string(sum);
		D = D_temp;
		D_temp = "";
	}
	printf("%s", D.c_str());
}

AC代码:

#include<bits/stdc++.h>
using namespace std;
int main() {
	string D,D_temp=""; int N;
 	cin >> D; scanf("%d", &N);
	for (int i = 0; i < N-1; i++) {
		int sum = 1; char temp = D[0];
		int len = D.length();
		for (int j = 1; j < len; j++) {
			if (temp == D[j]) sum++;
			else{
				D_temp += temp + to_string(sum);
				temp = D[j];
				sum = 1;
			}
		}
		D_temp += temp + to_string(sum);
		D = D_temp;
		D_temp = "";
	}
	printf("%s", D.c_str());
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值