Tree Recovery

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomlylooking binary  trees with capital letters in the nodes.This is an example of one of her creations:To record her trees for future generations, she wrote down two strings for each tree: a preordertraversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.She thought that such a pair of strings would give enough information to reconstruct the tree later(but she never tried it).Now, years later, looking again at the strings, she realized that reconstructing the trees was indeedpossible, but only because she never had used the same letter twice in the same tree.However, doing the reconstruction by hand, soon turned out to be tedious.So now she asks you to write a program that does the job for her!

Input

The input file will contain one or more test cases.Each test case consists of one line containing two strings ‘preord’ and ‘inord’, representing thepreorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters.(Thus they are not longer than 26 characters.)Input is terminated by end of file.

Output

For each test case, recover Valentine’s binary tree and print one line containing the tree’s postordertraversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG

BCAD CBAD

Sample Output

ACBFGED

CDAB

题意描述:给出二叉树的前序遍历和中序遍历,输出该二叉树的后序遍历。

解题思路:运用递归,每次摘出串的根,以及以根为分界点的左子树和右子树,在调用函数本身,对其左子树进行查找根,左子树

代码:

#include<stdio.h>
#include<string.h>
typedef struct stu{
	stu *r;
	stu *l;
	char d;
}st;
st* fun(char *s1,char *s2,int l)
{ 
    st *t;
    t=new st;
	int j;
	if(l<=0)
	  return NULL;
	t->l=t->r=NULL;
	t->d=*s1;
    for(j=0;j<l;j++)
	  if(*s1==s2[j])
	    break;
	t->l=fun(s1+1,s2,j);
	t->r=fun(s1+j+1,s2+j+1,l-j-1);
	return t;
}
void print(st *t)
{
	if(!t)
	  return ;
	print(t->l);
	print(t->r);
	printf("%c",t->d);
}
int main()
{    
    char s1[30],s2[30],s3[30];
	while(scanf("%s%*c%s",s1,s2)!=EOF)
	{
		print(fun(s1,s2,strlen(s1)));
		printf("\n");
	}
	return 0;
}
  
  
错误分析:函数入口的指针有错误,造成递归混乱,特殊数据没能通过,wa

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值