UVA - 536 Tree Recovery

42 篇文章 0 订阅

Description

Download as PDF

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

                                    D
                                   / \
                                  /   \
                                 B     E
                                / \     \
                               /   \     \ 
                              A     C     G
                                         /
                                        /
                                       F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).

For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).


Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!

Input Specification 

The input file will contain one or more test cases. Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.

Output Specification 

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input 

DBACEGF ABCDEFG
BCAD CBAD

Sample Output 

ACBFGED
CDAB

分析:基础的二叉树遍历,递归遍历先序和中序,生成后序:先序的第一个结点即根结点,然后在中序找到根结点的位置,左右两边即左子树和右子树,然后对两个子树在先序列中分别递归,注意中序中找到的下标和中序左端的差值实际上是左子树的结点个数,应该用先序的左端加这个差值去定位右子树(左子树和右子树结点数并不一致)。


#include <cstring>
#include <cstdio>

using namespace std;
const int maxn = 30;
char pre[maxn], in[maxn], post[maxn];
int T;

void order(int pL, int pR, int iL, int iR)
{
	if(pL>pR) return;
    char root = pre[pL];
    post[--T] = root;
    int i = iL;
    while(in[i]!=root) i++;
    int cnt = i - iL;
    order(pL+cnt+1, pR, i+1, iR);
    order(pL+1, pL+cnt, iL, i-1);
}

int main()
{
	while(~scanf("%s%s", pre, in)) {
		int len = strlen(pre);
		T = len;
		order(0, len-1, 0, len-1);
        post[len] = 0;
        printf("%s\n", post);
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值