04-树5 Root of AVL Tree (25 分)

04-树5 Root of AVL Tree (25 分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

思路

1.高度利用递归求解,不设height域

Code

#include<iostream>
#include<cmath>
using namespace std;
typedef struct AVLNode* AVL;
struct AVLNode {
    int data;
    AVL left;
    AVL right;
};
int GetHight(AVL T) {
    if(!T) return 0;
    else return max(GetHight(T->left), GetHight(T->right)) + 1;
}
AVL LeftLeft(AVL T){
    AVL temp =  T->left;
    T->left = temp->right;
    temp->right = T;
    return temp;
}
AVL RightRight(AVL T) {
    AVL temp = T->right;
    T->right = temp->left;
    temp->left = T;
    return temp;
}
AVL LeftRight(AVL T) {
    AVL temp = T->left;
    T->left = RightRight(temp);
    return LeftLeft(T);
}
AVL RightLeft(AVL T) {
    AVL temp = T->right;
    T->right = LeftLeft (temp);
    return RightRight(T);
}
AVL Insert(AVL T, int data) {
    if(!T) {
        T =  (AVL)malloc (sizeof(struct AVLNode));
        T->data = data;
        T->left = NULL;
        T->right = NULL;
    }
    else if(data < T->data){
        T->left = Insert(T->left, data);
        if(GetHight(T->left) - GetHight(T->right) == 2) {
            if(data < T->left->data) {
                T = LeftLeft(T);
            }
            else {
                T = LeftRight(T);
            }
        }
    }
    else if(data > T->data){
        T->right = Insert(T->right, data);
        if(GetHight(T->left) - GetHight(T->right) == -2) {
            if(data > T->right->data) {
                T = RightRight(T);
            }
            else {
                T = RightLeft(T);
            }
        }
    }
	return T;
}

int main() {
    AVL T = NULL;
    int num, data;
    cin >> num;
    for(int i = 0; i < num; i++) {
        cin >> data;
        T = Insert(T, data);
    }
    cout << T->data;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值