<数据结构浙大>04-树5 Root of AVL Tree (25 分)

AVL树的基本操作

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

F1.jpg

F2.jpg

F3.jpg

F4.jpg

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

结尾无空行

Sample Output 1:

70

结尾无空行

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

 图示分析:

 程序代码:

#include <stdio.h>
#include <stdlib.h>
typedef struct AVLNode* Position;
typedef Position AVLTree;
struct AVLNode {
	int data;
	AVLTree Left;
	AVLTree Right;
	int Height;
};
int Max(int a, int b)
{
	return a > b ? a : b;
}
int GetHeight(AVLTree T)
{
	int hl, hr, max;
	if (T)
	{
		hl = GetHeight(T->Left);
		hr = GetHeight(T->Right);
		max = Max(hl, hr);
		return max + 1;
	}
	return 0;
}
AVLTree SingleLeft(AVLTree A)//LL
{
	AVLTree B = A->Left;
	A->Left = B->Right;
	B->Right = A;
	A->Height = Max(GetHeight(A->Left), GetHeight(A->Right)) + 1;
	B->Height = Max(GetHeight(B->Left), A->Height) + 1;
	return B;
}
AVLTree SingleRight(AVLTree A)//RR
{
	AVLTree B = A->Right;
	A->Right = B->Left;
	B->Left = A;
	A->Height = Max(GetHeight(A->Left), GetHeight(A->Right)) + 1;
	B->Height = Max(GetHeight(B->Right), A->Height) + 1;
	return B;
}
AVLTree DoubleLeftRight(AVLTree A)//LR
{
	A->Left = SingleRight(A->Left);
	return SingleLeft(A);
}
AVLTree DoubleRightLeft(AVLTree A)//RL
{
	A->Right = SingleLeft(A->Right);
	return SingleRight(A);
}
AVLTree Insert(AVLTree T, int x)
{
	if (T == NULL)
	{
		T = (AVLTree)malloc(sizeof(struct AVLNode));
		T->data = x;
		T->Height = 0;//1?
		T->Left = T->Right = NULL;
	}
	else if (x < T->data)
	{
		T->Left = Insert(T->Left, x);
		if (GetHeight(T->Left) - GetHeight(T->Right) == 2)
			if (x < T->Left->data)//LL
				T = SingleLeft(T);
			else
				T = DoubleLeftRight(T);//LR
	}//插入左子树结束
	else if (x > T->data)
	{
		T->Right = Insert(T->Right, x);
		if (GetHeight(T->Left) - GetHeight(T->Right) == -2)
			if (x > T->Right->data)//RR
				T = SingleRight(T);
			else
				T = DoubleRightLeft(T);//RL
	}//插入右子树结束 若x==T->data 无需操作
	T->Height = Max(GetHeight(T->Left), GetHeight(T->Right));
	return T;
}
int main()
{
	AVLTree T=NULL;
	int N,x;
	scanf("%d", &N);
	for (int i = 0; i < N;i++)
	{
		scanf("%d", &x);
		T = Insert(T, x);
	}
	printf("%d", T->data);
}

 

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zbc-

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值