1056 Mice and Rice (25 分)

1056 Mice and Rice (25 分)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.
First the playing order is randomly decided for N
​P
​​ programmers. Then every N
​G
​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N
​G
​​ winners are then grouped in the next match until a final winner is determined.
For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N
​P
​​ and N
​G
​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N
​G
​​ mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains N
​P
​​ distinct non-negative numbers W
​i
​​ (i=0,⋯,N
​P
​​−1) where each W
​i
​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N
​P
​​−1 (assume that the programmers are numbered from 0 to N
​P
​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

Note

  1. 题意: n个老鼠,m个一组比重量,选出一个优胜的进入下一轮比赛,其他老鼠排名相同
  2. 思路:(看了答案后才想到的)
    - 当前比赛组数加一即为没有晋级的老鼠排名,晋级了的会再被覆盖掉
    - 用队列存储老鼠比赛顺序的下标,每一轮比赛都会把所有下标清出队列再把优胜者push进去

Code

#include<iostream>
#include<queue>
using namespace std;
# define MAX 100000
struct node{
    int weight;
    int Rank;
} a[MAX];
int main() {
    int num, comp;
    queue <int> q;
    cin >> num >> comp;
    for(int i = 0; i < num; i++){
        cin >> a[i].weight;
    }
    for(int i = 0; i < num; i++){
        int temp;
        cin >> temp;
        q.push(temp);
    }
    int mouse = num;
    while(q.size() > 1){
        int group = (mouse % comp == 0) ?  mouse / comp : mouse / comp +1;
        for(int i = 0; i < group; i++){
            int max = 0, ptr = -1;
            for(int j = 0; j < comp; j++){
                if(i*comp + j == mouse) break;
                if(a[q.front()].weight > max){
                    max = a[q.front()].weight;
                    ptr = q.front();
                }
                a[q.front()].Rank = group + 1;
                q.pop();
            }
            if(ptr != -1)
                q.push(ptr);
        }
        mouse = group;
    }
    a[q.front()].Rank = 1;
    cout << a[0].Rank;
    for(int i = 1; i < num; i++){
        cout << " " <<  a[i].Rank;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值