1006. Couples

Description

N couples are standing in a circle, numbered consecutively clockwise from 1 to 2N. Husband and wife do not always stand together. We remove the couples who stand together until the circle is empty or we can't remove a couple any more. Can we remove all the couples out of the circle? 

Input

 There are multiple test cases. The first line contains an integer T, indicating the number of test cases. In each case, the first line is an integer N(1 <= N <= 100000)----the number of couples. In the following N lines, each line contains two integers ---- the numbers of each couple.

Output

 Output "Yes" if we can remove all the couples out of the circle. Otherwise, output "No".

Sample Input
 Copy sample input to clipboard
2
4
1 4 
2 3 
5 6 
7 8
2 
1 3 
2 4 
Sample Output
Yes 
No
 
     
 
各种各样的错误
算是熬过来了 弄了一上午
#include<iostream>
#include<stack>
using namespace std;
int main() {
    int num,num1,a,b,num2[200002]= {0};
    stack<int> sta;
    cin>>num;
    for(int i=0; i<num; i++) {
        cin>>num1;
        for(int j=0; j<num1; j++) {
            cin>>a>>b;
            if(a<b)num2[b]=a;
            else num2[a]=b;
        }
        for(int j=1; j<=2*num1; j++) {
            if(num2[j]==0)
                sta.push(j);
            else if(num2[j]==sta.top())
                sta.pop();
            else
                break;
        }
        if(sta.empty())
            cout<<"Yes"<<endl;
        else
            cout<<"No"<<endl;
    }
}                                 
这是WA,测试Sample Input并没有问题
后来把两者顺序颠倒一下测试
发现stack没有清空
之后用了一个while清空stack
#include<iostream>
#include<stack>
using namespace std;
int main() {
    int num,num1,a,b,num2[200002]= {0};
    stack<int> sta;
    cin>>num;
    for(int i=0; i<num; i++) {
        cin>>num1;
        for(int j=0; j<num1; j++) {
            cin>>a>>b;
            if(a<b)num2[b]=a;
            else num2[a]=b;
        }
        for(int j=1; j<=2*num1; j++) {
            if(num2[j]==0)
                sta.push(j);
            else if(num2[j]==sta.top())
                sta.pop();
            else
                break;
        }
        if(sta.empty())
            cout<<"Yes"<<endl;
        else
            cout<<"No"<<endl;
        while(!sta.empty())sta.pop();
    }
}                                 
出来的结果是RE
看遍整个程序没发现什么可优化的地方(是我技术太差)
后来找到一种办法可以把while去掉
把stack<int> sta放到for循环中
每次结束后重新构造一个stack
#include<iostream>
#include<stack>
using namespace std;
int main() {
    int num,num1,a,b,num2[200002]= {0};
    cin>>num;
    for(int i=0; i<num; i++) {
        cin>>num1;
        stack<int> sta;
        for(int j=0; j<num1; j++) {
            cin>>a>>b;
            if(a<b)num2[b]=a;
            else num2[a]=b;
        }
        for(int j=1; j<=2*num1; j++) {
            if(num2[j]==0)
                sta.push(j);
            else if(num2[j]==sta.top())
                sta.pop();
            else
                break;
        }
        if(sta.empty())
            cout<<"Yes"<<endl;
        else
            cout<<"No"<<endl;
    }
}                                 
结果继续RE
顿时炸了...
那输入输出没法优化
唯一能优化的就是两个for里面的语句
我在想能不能少用一点if
于是有了这样的代码
#include<iostream>
#include<stack>
using namespace std;
int main() {
    int num,num1,a,b,num2[200002]= {0};
    cin>>num;
    for(int i=0; i<num; i++) {
        cin>>num1;
        for(int j=1; j<=num1; j++) {
            cin>>a>>b;
            num2[a]=num2[b]=j;
        }
        stack<int> sta;
        for(int j=1;j<=2*num1;j++) {
            if(sta.empty()||sta.top()!=num2[j])
                sta.push(num2[j]) ;
            else 
                sta.pop() ;
        }
        if(sta.empty())
            cout<<"Yes"<<endl;
        else
            cout<<"No"<<endl;
    }
}                                 

于是AC了...
两个for都改了
如果有高手能解答一下这个程序到底是哪一步快了就最好了-,-



 
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值