1021. Couples 栈和数组的实现

1021. Couples

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

N couples are standing in a circle, numbered consecutively clockwise from 1 to 2N. Husband and wife do not always stand together. We remove the couples who stand together until the circle is empty or we can't remove a couple any more.

Can we remove all the couples out of the circle?

Input

There may be several test cases in the input file. In each case, the first line is an integerN(1 <= N <= 100000)----the number of couples. In the following N lines, each line contains two integers ---- the numbers of each couple.
N = 0 indicates the end of the input.

Output

Output "Yes" if we can remove all the couples out of the circle. Otherwise, output "No".

Sample Input

4
1 4
2 3
5 6
7 8

2
1 3
2 4

0

Sample Output

Yes
No

Problem Source

ZSUACM Team Member


很简单的题啊啊啊,和符号匹配很像。

上代码

#include <iostream>
#include <stack>

using namespace std;

int main() {
	int N;
	while(cin >> N, N != 0) {
		int couple[200005] = {0};
		stack<int> pair;
		//对夫妻设置同样的号码1~N(夫妻代表的号码作为各自下标号)
		for (int i = 1; i <= N; i++) {
			int a, b;
			cin>>a>>b;
			couple[a] = couple[b]= i;
		}
		for (int i = 1; i <= 2*N; i++) {
			if (pair.empty() || couple[i] != pair.top()) //若栈为空或夫妻不匹配,则入栈
				pair.push(couple[i]);
			else
				pair.pop();	//否则(夫妻匹配)出栈	
		}
		if (pair.size() > 0)
			cout<<"No"<<endl;
		else
			cout<<"Yes"<<endl;	
	}

	//system("pause");
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值