HDU 2767 Proving Equivalences(至少增加多少条边使得有向图变成强连通图)

Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9296    Accepted Submission(s): 3281


Problem Description
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
 

 

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.
 

 

Output
Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.
 

 

Sample Input
2 4 0 3 2 1 2 1 3
 

 

Sample Output
4 2
 

 

Source
 
分析:
给你一个有向图,问你至少添加多少条边,使得该图变成一个强连通图
特判情况:
m=0,没有边,那么至少添加n条边
sig=1,该图本来就是强连通图,则输出0
tarjan求强连通分量,同时染色缩点得到新图
统计新图入度为0和出度为0的点的个数
输出最大值,就是我们至少需要添加的边的条数
原因:
缩点的原因:
强连通分量内部是互相可达的,我们只有把这些强连通分量缩成一个点,然后使得这些点构成的新图变成强连通图就可以了
所以问题得到关键是:
怎么使得新图变成强连通图(新图中不存在强连通分量,本身也不是强连通图)
有向图没有构成环的话,肯定存在链
把链头和链尾安装某个方向连接起来
链就变成环了
所以看看链头和链尾的个数就好(即出度为0和入度为0的点)
输出链头和链尾个数的最大值
为什么是最大值?
因为如果连最小值条边的话,新图不一定能够变成强连通图
 
code:
#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string.h>
#include<set>
#include<map>
#include<list>
#include<math.h>
#include<queue>
#include<algorithm>
using namespace std;
typedef long long LL;
#define INF 0x7fffffff
int mon1[13]= {0,31,28,31,30,31,30,31,31,30,31,30,31};
int mon2[13]= {0,31,29,31,30,31,30,31,31,30,31,30,31};
int dir[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};

int getval()
{
    int ret(0);
    char c;
    while((c=getchar())==' '||c=='\n'||c=='\r');
    ret=c-'0';
    while((c=getchar())!=' '&&c!='\n'&&c!='\r')
        ret=ret*10+c-'0';
    return ret;
}

#define max_v 20005
#define mem(a,x) memset(a,x,sizeof(a))
int vis[max_v];
int dfn[max_v];
int low[max_v];
int color[max_v];
int stk[max_v];
int indgree[max_v];
int outdgree[max_v];
vector<int> G[max_v];
int n,m;
int sig,cnt,sp;

void init()
{
    mem(indgree,0);
    mem(outdgree,0);
    mem(vis,0);
    mem(dfn,0);
    mem(low,0);
    mem(color,0);
    mem(stk,0);
    for(int i=1;i<=n;i++)
        G[i].clear();
    sig=0;
    cnt=1;
    sp=-1;
}

void tarjan(int u)
{
    vis[u]=1;
    low[u]=dfn[u]=cnt++;
    stk[++sp]=u;

    for(int j=0;j<G[u].size();j++)
    {
        int v=G[u][j];
        if(vis[v]==0)
            tarjan(v);
        if(vis[v]==1)
            low[u]=min(low[u],low[v]);
    }
    if(low[u]==dfn[u])
    {
        sig++;
        do
        {
            vis[stk[sp]]=-1;
            color[stk[sp]]=sig;
        }while(stk[sp--]!=u);
    }
}
int main()
{
    int t;
    int x,y;
    cin>>t;
    while(t--)
    {
        scanf("%d %d",&n,&m);
        if(m==0)
        {
            printf("%d\n",n);
            continue;
        }
        init();
        for(int i=1;i<=m;i++)
        {
            scanf("%d %d",&x,&y);
            if(x==y)
                continue;
            if(count(G[x].begin(),G[x].end(),y)==0)
                G[x].push_back(y);
        }

        for(int i=1;i<=n;i++)
        {
            if(vis[i]==0)
                tarjan(i);
        }

        if(sig==1)
        {
            printf("0\n");
            continue;
        }
       // printf("sig=%d\n",sig);
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<G[i].size();j++)
            {
                int v=G[i][j];
                if(color[i]!=color[v])
                {
                    indgree[color[v]]++;
                    outdgree[color[i]]++;
                }
            }
        }
        LL ans=0,ans1=0,ans2=0;
        for(int i=1;i<=sig;i++)
        {
            if(indgree[i]==0)
                ans1++;
            if(outdgree[i]==0)
                ans2++;
        }
        ans=max(ans1,ans2);
        printf("%d\n",ans);
    }
    return 0;
}
/*
给你一个有向图,问你至少添加多少条边,使得该图变成一个强连通图

特判情况:
m=0,没有边,那么至少添加n条边
sig=1,该图本来就是强连通图,则输出0

tarjan求强连通分量,同时染色缩点得到新图
统计新图入度为0和出度为0的点的个数
输出最大值,就是我们至少需要添加的边的条数

原因:
缩点的原因:
强连通分量内部是互相可达的,我们只有把这些强连通分量缩成一个点,然后使得这些点构成的新图变成强连通图就可以了
所以问题得到关键是:
怎么使得新图变成强连通图(新图中不存在强连通分量,本身也不是强连通图)
有向图没有构成环的话,肯定存在链
把链头和链尾安装某个方向连接起来
链就变成环了
所以看看链头和链尾的个数就好(即出度为0和入度为0的点)
输出链头和链尾个数的最大值

为什么是最大值?
因为如果连最小值条边的话,新图不一定能够变成强连通图

*/

 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值