2021-08-26 AcWing 3816. 移动元素

 思路:哈希表

输入样例:

3
3
1 3 2
5
1 2 3 4 5
5
2 2 3 4 5

输出样例:

YES
NO
YES

#include <iostream>
#include <cstring>
#include <algorithm>
#include <unordered_map>
using namespace std;

typedef long long LL;

const int N = 1e5+10;
int a[N];
int n;

void check()
{
    unordered_map<LL, int>cnt1,cnt2;
    LL sum = 0;
    
    for (int i = 0; i < n; i ++ )
    {
        scanf("%d", &a[i]);
        cnt1[a[i]] ++;
        sum += a[i];
    }
    if(sum%2){
        cout << "NO" << endl;
        return ;
    }
    
    LL s=0;
    LL half = sum >> 1;
    for (int i = 0; i < n; i ++ )
    {
        s += a[i];
        cnt1[a[i]]--;//前半部分已被选中的,对应的value减一;
        cnt2[a[i]]++;
        if(cnt1[half-s]>0 || cnt2[s-half]>0){
            cout << "YES" << endl;
            return ;
        }
    }
    cout << "NO" << endl;
}

int main()
{
    int t;
    cin >> t;
    while (t -- )
    {
        cin >> n;
        check();
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

泥烟

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值