HDU1789

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

题目大意:每个作业需要一天完成,给定deadline和对应的扣分值,求最少扣的分数

思路:将扣的分值从大到小排列,如果相同,则按deadline从小到大排列,优先完成分值大的作业,从该作业的deadline往前搜索,找到一天来完成该作业,然后标记这一天。

#include<cstdio>
#include<string.h>
#include<queue>
#include<vector>
#include<map>
#include<stack>
#include<set>
#include<algorithm>
using namespace std;
#define INF 1<<28
static const int MAX = 1050;

//按扣分从大到小排序,分数相同则按截止日期从小到大排序
struct node{
    int ddl;    //截止日期
    int rs;     //扣分
    bool operator < (const struct node &p) const
    {
        if (rs != p.rs)
            return rs > p.rs;
        return ddl < p.ddl;
    }
}A[MAX];
int used[MAX];  //当天是否已有作业的标记

int main()
{
    int T;
    scanf("%d", &T);

    while (T--)
    {
        int n;
        scanf("%d", &n);

        memset(used, 0, sizeof(used));

        for (int i = 0; i < n; i++)
            scanf("%d", &A[i].ddl);
        for (int i = 0; i < n; i++)
            scanf("%d", &A[i].rs);

        sort(A, A + n);
        int ans = 0;

        for (int i = 0; i < n; i++)
        {
            int j = A[i].ddl;
            for (; j >= 1; j--)
            {
                if (used[j] == 0)
                {
                    used[j] = 1;
                    break;
                }
            }
            if (j == 0)
                ans += A[i].rs;
        }
        printf("%d\n", ans);
    }
    return 0;
}






 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值