POJ 3278(bfs)

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 32679 Accepted: 10060
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
    If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
    Input
    Line 1: Two space-separated integers: N and K
    Output
    Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
    Sample Input
    5 17
    Sample Output
    4
    Hint
    The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
#include<iostream>
#include<queue>
using namespace std;
const int maxn=100001;
int step[100000];
int vis[100000];
queue<int> q;
int n,k;
int bfs(int n,int k){
    q.push(n);
    step[n]=0;
    vis[n]=1;
    while(!q.empty()){
        int head,next;
        head=q.front();
        q.pop();
        for(int i=0;i<3;i++){
            if(i==0)    next=head-1;
            else if(i==1)    next=head+1;
            else     next=head*2;
            if(next<0 || next>maxn) continue;
            if(!vis[next]){
                step[next]=step[head]+1;
                q.push(next);
                vis[next]=1;
                if(next==k) return step[next];
            } 
        }
    }
}
int main()
{
    while(cin >> n >> k){
    	while(!q.empty()) q.pop();
   
    	if(n>k) cout << n-k << endl;
    	else
    	cout <<bfs(n,k) << endl;
	}
    return 0;

}

像下面这样判断终止条件时,要考虑第一个入队的元素没有判断。

#include<iostream>
#include<cstring>
#include<queue>
using namespace std;

const int maxn = 100001;
struct pos{
    int x;
    int t;
};
int n, k;
int vis[maxn];
bool check(int x){
    if(x >= 0 && x <= maxn)
        return true;
    return false;
}
void bfs(){
    queue<pos> q;

    memset(vis, 0, sizeof vis);
    pos f;
    f.x=n;
    f.t=0;
    vis[f.x] = 1;
    q.push(f);
    while(!q.empty()){
        pos cur = q.front();
        q.pop();
        pos next;
        next.t = cur.t+1;
        if(check(cur.x+1) && vis[cur.x+1] == 0){
            next.x = cur.x+1;
            vis[next.x] = 1;
            q.push(next);
            if(next.x == k){
                cout << next.t;
                return ;
            }
        }
        if(check(cur.x-1) && vis[cur.x-1] == 0){
            next.x = cur.x-1;
            vis[next.x] = 1;
            q.push(next);
             if(next.x == k){
                cout << next.t;
                return ;
            }
        }
        if(check(cur.x*2) && vis[cur.x*2] == 0){
            next.x = cur.x*2;
            vis[next.x] = 1;
            q.push(next);
             if(next.x == k){
                cout << next.t;
                return ;
            }
        }
    }
}
int main(){
    cin >> n >> k;
    if(n == k)
        cout << 0;
    else
        bfs();
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值