1128 N Queens Puzzle(20 分)

1128 N Queens Puzzle(20 分)

The “eight queens puzzle” is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - “Eight queens puzzle”.)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q​1​​,Q​2​​,⋯,Q​N​​), where Q​i​​ is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens’ solution.
这里写图片描述 这里写图片描述
Input Specification:

Each input file contains several test cases. The first line gives an integer K (1 < K ≤ 200). Then K lines follow, each gives a configuration in the format “N Q​1​​ Q​2​​ … Q​N​​”, where 4≤N≤1000 and it is guaranteed that 1≤Q​i​​≤N for all i=1,⋯,N. The numbers are separated by spaces.
Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.
Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES
思路:不要受以前学过的八皇后的影响,把它当成一道新题做,很简单,连深搜都用不上。
需要注意的是输入的下标从1开始,所以我们a数组下标也从1开始!

#include <iostream>
#include <cstring>
using namespace std;

int main(){
    int N;
    cin >> N;
    while(N--){
        int n;
        cin >> n;
        int a[n+1];
        int book[n+1];
        int flag = 1;
        memset(book,0,sizeof book);
        for(int i = 1; i <= n; i++){
            cin >> a[i];
            if(book[a[i]] == 0){
                book[a[i]] = 1;
            }
            else{
                flag = 0;
            }

            if(flag){
                for(int j = 1; j < i; j++){
                    if(a[i] - a[j] == i - j || a[i] - a[j] == j - i){
                        flag = 0;
                    }
                }
            }
        }
        if(flag){
            cout << "YES" << endl;
        }
        else
            cout << "NO" << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值