1018 Public Bike Management(Dijkstra + dfs)

12 篇文章 0 订阅
10 篇文章 0 订阅

部分内容引用自:
https://www.liuchuo.net/archives/2373
1018 Public Bike Management(30 分)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.
这里写图片描述

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​, we have 2 different shortest paths:

PBMC -> S​1​​ -> S​3​​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​, so that both stations will be in perfect conditions.

PBMC -> S​2​​ -> S​3​​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p​​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​, S​j​​, and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​−>⋯−>S​p​​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.
Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

题目大意:每个自行车车站的最大容量为一个偶数cmax,如果一个车站里面自行车的数量恰好为cmax / 2,那么称处于完美状态。如果一个车站容量是满的或者空的,控制中心(处于结点0处)就会携带或者从路上收集一定数量的自行车前往该车站,一路上会让所有的车站沿途都达到完美。现在给出cmax,车站的数量n,问题车站sp,m条边,还有距离,求最短路径。如果最短路径有多个,求能带的最少的自行车数目的那条。如果还是有很多条不同的路,那么就找一个从车站带回的自行车数目最少的。带回的时候是不调整的

分析:dijkstra求出最短路径(可能是多条),dfs模拟。

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>
using namespace std;

const int inf = 99999999;

int w[510];
vector<int> pre[510];
vector<int> tmp, path;
int minBring = inf, minTake = inf;
void dfs(int v){
    tmp.push_back(v);
    if(v == 0){
        int bring = 0, take = 0, cur = 0;
        for(int i = tmp.size()-1; i >= 0; i--){
            if(w[tmp[i]] > 0){
                cur += w[tmp[i]];
            }else if(w[tmp[i]] < 0){
                if(cur > -w[tmp[i]]){
                    cur += w[tmp[i]];
                }else{
                    bring += -(w[tmp[i]]+cur);
                    cur = 0;
                }
            }
        }
        take = cur;
        if(minBring > bring){
            path = tmp;
            minBring = bring;
            minTake = take;
        }else if(minBring == bring && minTake > take){
            path = tmp;
            minTake = take;
        }
        tmp.pop_back();
        return ;
    }
    for(int i = 0; i < pre[v].size(); i++)
        dfs(pre[v][i]);
    tmp.pop_back();
}
int main() {
    int cmax, N, sp, M;
    cin >> cmax >> N >> sp >> M;
    int e[N+10][N+10];
    int dis[N+10];
    int book[N+10];
    memset(book, 0, sizeof book);
    fill(e[0], e[0]+(N+10)*(N+10), inf);
    fill(dis, dis+(N+10)*(N+10), inf);
    for(int i = 1; i <= N; i++){
        scanf("%d", &w[i]);
        w[i] = w[i] - cmax/2;
    }
    int a, b, c;
    for(int i = 0; i < M; i++){
        scanf("%d%d%d", &a, &b, &c);
        e[a][b] = e[b][a] = c;
    }
    dis[0] = 0;
    for(int i = 0; i <= N; i++){
        int u = -1, minn = inf;
        for(int j = 0; j <= N; j++){
            if(book[j] == 0 && dis[j] < minn){
                u = j;
                minn = dis[j];
            }
        }
        book[u] = 1;
        for(int v = 0; v <= N; v++){
            if(book[v] == 0 && e[u][v] != inf){
                if (dis[v] > dis[u] + e[u][v]){
                    dis[v] = dis[u] + e[u][v];
                    pre[v].clear();
                    pre[v].push_back(u);
                } else if(dis[v] == dis[u] + e[u][v]){
                    pre[v].push_back(u);
                }
            }
        }
    }
    dfs(sp);
    printf("%d %d", minBring, path[path.size()-1]);
    for(int i = path.size()-2; i>= 0; i--){
        printf("->%d", path[i]);
    }
    printf(" %d", minTake);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值