1018. Public Bike Management (Dijkstra + DFS)

1018 Public Bike Management (30 分)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​, we have 2 different shortest paths:

  1. PBMC -> S​1​​ -> S​3​​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​, so that both stations will be in perfect conditions.

  2. PBMC -> S​2​​ -> S​3​​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p​​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​, S​j​​, and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​−>⋯−>S​p​​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

/**
1.此题思路 通过dijkstra找到对短路径后,并将到规定点所有最短路径找到, 通过dfs筛选出满足题意的一条路径

2.: vector<vector<int>>allpath(520); c++表示二维向量的第二种方法 :vector<int>allpath[520]
   在code::blocks ide编译器中 定义vector<vector<> > 需要在vector<>结尾处多打一个空格  
   
3.:c++中vector容器 push_back()放入元素,clear()清除元素;
4.: c++ 中全局变量默认初始化,局部变量不会初始化
5.
 调出devc++中的调试窗口 点击视图 浮动项目管理器
**/

 

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;


const int inf=0x3f3f3f;
bool visit[520];
int edge[520][520];
int dis[520];
int weight[520];
int cmax,n,sp,m;					 
vector<vector<int>>allpath(520);    //定义二维向量容器 存放到对应结点最短距离的父节点(该容器存储了所有路径) 
vector<int> path,temppath;          //path为需要输出的路径,temppath为临时存储到问题结点的其中一条路径 
int minneed=inf,minback=inf;
//
void dfs(int m){
	temppath.push_back(m);
//	for(auto it=temppath.begin();it!=temppath.end();it++){
//		cout<<*it<<endl; 
//	}
	if(m==0){
		int need=0,back=0;
		//int i=0;i<temppath.size();i++ 带回的时候是不调整的(这点很重要 不能从问题结点开始) 此种是错误写法  
		for(int i=temppath.size()-1;i>=0;i--){ //??? 
			int id=temppath[i];
			if(weight[id]>0){    // >0表示需要返回的自从车数 
			back+=weight[id];                
			}else{ //表示该点需要 0号点发送的自行车 
				if(back>(0-weight[id])){   //当需要返回的车 大于 该点需要的自行车数 (需要返回的结点只能继续给下面需要的点补充,不能给更早缺失的车补充 ) 
					back-=(0-weight[id]);  
				}else{
					need+=(0-weight[id]-back); //需要的自行车量 大于 需要返回的自行车时 
					back=0;
				}
			}
		}
		//表示此时已经遍历完一条路径了 
		//根据题意 ,需要选出被需要的车最少的路径 
		if(need < minneed){  // 
			minneed=need;
			minback=back;
			path=temppath;
		}else if(need==minneed && back<minback){ // 如果被需要车最少的路径相同 ,则筛选出返回的车最少的路径 
			minback=back;
			path=temppath;
		}
		
	}else{
		for(int i=0;i<allpath[m].size();i++){
			dfs(allpath[m][i]);
			temppath.pop_back();
		}
	}	
		
}
void dijkstra(int start){
	dis[start]=0;
	for(int i=0;i<=n;i++){
		int min=inf,u;
		for(int j=0;j<=n;j++){
			if(dis[j]<min && visit[j]==false){
				min=dis[j];
				u=j;
			}
		}
		if(min==inf) break;
		visit[u]=true;
		for(int k=0;k<=n;k++){
			if(visit[k] ==false && edge[u][k]!=inf){  //这个位置着重注意  此处是 edge[u][k]!=inf(当edge为inf时无论松弛边怎么相加都是inf) 不要写为dis[k]!=inf 
				if(dis[u]+edge[u][k]<dis[k]){     //存在更短的路径 
					dis[k]=dis[u]+edge[u][k];
					allpath[k].clear();           //当存在更短的路径 表示此时到 u->k这条路径更短(直接更新到该结点的父节点 ) 
					allpath[k].push_back(u);			 
				}else if(dis[u]+edge[u][k]==dis[k]){
					allpath[k].push_back(u);     //说明存在相同的更短路径, 将路径压入二维向量容器中 
				}	 
			}
		
		}
	}
}
int main(){
	fill(edge[0],edge[0]+520*520,inf);
	fill(dis,dis+520,inf); 
	scanf("%d%d%d%d",&cmax,&n,&sp,&m);
	for(int i=1;i<=n;i++){
		scanf("%d",&weight[i]);
		weight[i]=weight[i]-cmax/2;
	}
	while(m--){
		int from,to,cost;
		scanf("%d%d%d",&from,&to,&cost);
		edge[from][to]=edge[to][from]=min(cost,edge[from][to]);
	}
	dijkstra(0);
	dfs(sp);
	printf("%d 0",minneed);  //首结点始终是从0出发 
	for(int i=path.size()-2;i>=0;i--){ //因为path中存放的路径是倒叙  (0被提前输出) 倒叙输出 
		printf("->%d",path[i]);
	}
	printf(" %d",minback);		
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值