Subsequence 尺取法

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3


思路来源:https://blog.csdn.net/helloiamclh/article/details/47685927

#include<iostream>
using namespace std;
#define min(a,b) a>b?b:a;
#define MAXN 100010
#define INF 0xfffffff
int a[MAXN];
int main()
{
	int n,N,S,l,r,len;
	long long sum  = 0;
	cin >>n;
	while(n--){
		cin>>N>>S;
		for(int i=0;i<N;i++){
			cin>>a[i];
		}
		l = r = 0;//初始化 
		sum = 0;
		len = INF;
		while(1){
			while(r<N && sum<S){ 
				sum+=a[r];
				r++;
			}//此时的sum是区间[l,r)上的和 
			if(sum<S){//如果说 sum<S但是r>=N了 结束循环 
				break;
			} 
			len = min(len,r-l);//更新长度 取较小的 
			sum -= a[l];//看看减去左边一个元素 还满不满足sum>=S 
			l++; //l右移一个 
		}
		if(len == INF){//如果说len没有变化 说明所有的数加起来<S 
			cout<<"0"<<endl; 
		}
		else{
			cout<<len<<endl;
		}
	}
	return 0;
}
最大子列和问题

给定N个整数的序列 a1,a2,,,,,, an 求 求做大子列和,如果子列和为负数,那么结果为0

#include<iostream>
using namespace std;
int a[100100];
int main()
{
	int maxsum,sum,N;
	maxsum = sum = 0;
	cin>>N;
	for(int i=0;i<N;i++){
		cin>>a[i];
	}//先读入数据 
	for(int i=0;i<N;i++){
		sum += a[i];
		if(sum > maxsum){
			maxsum = sum;
		}
		else if(sum <0 ){
			sum = 0;
		}
	}
	cout<<maxsum<<endl;
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值