Subsequence(连续字段和最小并且大于S)

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and
a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the
subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input
Many test cases will be given. For each test case the program has to read the numbers N and S,
separated by an interval, from the first line. The numbers of the sequence are given in the second line
of the test case, separated by intervals. The input will finish with the end of file.

Output
For each the case the program has to print the result on separate line of the output file.

Sample Input
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output
2
3
题目大概意思:连续字段和最小并且大于S!
本质上还是一道前缀和的题目!

#include <cstring>
#include <cstdio>
#include <iostream>
using namespace std;
typedef long long LL;
const int N = 1e5 + 10;
int a[N];

int solve(int n, int s)
{
    int res = n + 1;
    int start = 0, end = 0, sum = 0;
    for(;;)
    {
        while(end < n && sum < s)
            sum += a[++ end];
        
        //为什么要写sum < s才可退出循环,两个原因
        //1.此条件可保证遍历完全部的a[i],也就是O(n)的
        //2.由于上边的while循环所导致,所以sum只有遍历完之后才会break
        if(sum < s) break;
        
        res = min(res, end - start);
        sum -= a[++ start];
    }
    return res > n ? 0 : res;
}

int main()
{
    int n, s;
    while(cin >> n >> s)
    {
        for(int i = 1; i <= n; i ++ ) cin >> a[i];
        
        cout << solve(n, s) << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值