POJ3624(01背包)

Charm Bracelet
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 43634 Accepted: 18778
Description

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

  • Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7
Sample Output

23
Source

USACO 2007 December Silver

#include <iostream>
using namespace std;
int N, M;
int value[1001] = {0}, volume[1001] = {0};
int bag[1001] = {0};
int main() {
    cin >> N >> M;
    for (int i = 1; i <= N; i++)
        cin >> volume[i] >> value[i];
    for (int i = 1; i <= N; i++) {
        for (int j = M; j >= 1; j--) {
            if (volume[i] <= j)
                bag[j] = max(bag[j-volume[i]] + value[i], bag[j]);
        }
    }
    cout << bag[M];
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值