Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0 through 9 once each, such that the first number divided by the second is equal to an integer N, where 2<=N<=79. That is,
abcde/fghij=N
where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.
Input
Each line of the input file consists of a valid integerN. An input of zero is to terminate the program.
Output
Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and,
of course, denominator).
Your output should be in the following general form:
xxxxx/xxxxx=N
xxxxx/xxxxx=N
.
.
In case there are no pairs of numerals satisfying the condition, you must write ‘
There are no solutions for N.’. Separate the output for two different values of
N
by a blank line.
Sample Input
61
62
0
Sample Output
There are no solutions for 61.
79546 / 01283 = 62
94736 / 01528 = 62
题目大意&解题思路:给出一个数x,输出所有形如abcde / fghij = x的算式,根据x,穷举所有可能的分子值,即从1至98765/x便将枚举量压缩至1w以内,对于每一对分母分子,再利用函数判断是否有重复数字,若无,则做为为可行解之一输出。
暴搜入门水题,建议手动尝试。
偷偷贴上注释代码。
#include <cstdio>
#include <cstring>
#include <set>
#include <iostream>
using namespace std;
int judge(int m,int z){
int mid;
if(z<=1000) return 0;
set<int> s; //利用std::set集合来判断是否有重复元素
s.clear();
if(z<10000) s.insert(0);
if(z<10000 && m<10000) return 0;
while(z!=0){ //分子逐位入集合
mid=z%10;
if(s.find(mid)==s.end())s.insert(mid); //若返回不为s.end(),说明集合内已有该元素。
else return 0;
z=z/10;
}
while(m!=0){ //分母逐位入集合
mid=m%10;
if(s.find(mid)==s.end()) s.insert(mid);
else return 0;
m=m/10;
}
return 1;
}
int main(){
int x,flag,mu,zi,kase=0;
while(scanf("%d",&x) && x){
if(kase++) printf("\n"); //注意题目输出格式,否则会PE
flag=0;
if(x>98765) continue;
for(int i=1;i<=98765/x;i++) {
zi=i;
mu=zi*x;
if(judge(mu,zi)){
flag=1;
printf("%05d / %05d = %d\n",mu,zi,x);
}
}
if(flag==0) printf("There are no solutions for %d.\n",x);
}
return 0;
}