HDU 1016 && Uva 524 Prime Ring Problem(素数环)

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

 
Inputn (0 < n < 20). 
OutputThe output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题目大意 && 解题思路:输入正整数n,把1,2,3,4. . .n组成一个环,使得相邻两个整数之和均为素数。输出从整数1开始的逆时针序列。如果一一枚举,则运算量为n!,并逐个测试会超时。因此,利用回溯法,尝试在cur位置填入可行的数字,再递归调用,在cur+1位置填入可行的数字,直至cur==n输出可行解,注意递归调用后要将vis值恢复。

上代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
using namespace std;

const int maxn=21;
int A[maxn];
int vis[maxn];
int n;
int isp(int x){
    if(x==1) return 0;
    for(int i=2;i<=sqrt(x);i++){
        if(x%i==0) return 0;
    }
    return 1;
}
void dfs(int cur){
    if(cur==n && isp(A[0]+A[n-1])){
        for(int i=0;i<n;i++) {printf("%s%d",!i?"":" ",A[i]);}
        printf("\n");
    }
    else for(int i=2;i<=n;i++)
        if(!vis[i]  && isp(i+A[cur-1])){
            A[cur]=i;
            vis[i]=1;
            dfs(cur+1);
            vis[i]=0;
        }
}

int main(){
    int kase=0;
    while(scanf("%d",&n)!=EOF){
        if(kase) printf("\n");
        printf("Case %d:\n",++kase);
        memset(A, 0, sizeof(A));
        memset(vis, 0, sizeof(vis));
        A[0]=1;
        dfs(1);
        
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值