【codeup】6114 Problem A Course List for Student

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.
浙江大学有40000个学生以及提供了2500门课程,现在给出每门课程的学生姓名表,你需要将每个来查找自己所选课程的学生的课程表输出。

输入

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.
每个输入文件包含一个测试用例。对每一个用例,第一行包括两个正整数:N(<=40000),查询自己课程表的学生数和K(<=2500),课程总数量。
之后课程(从1到K编号)的所选学生姓名链会以如下方式给出:对任一门课程i,课程编号i和选这门课的学生数量Ni(<=200)会在第一行给出,下一行会给出Ni个学生的姓名。学生的姓名由3个大写的英文字母加一位数字组成。最后一行会将想要查询自己课程情况的N个学生的姓名给出。同一行的所有姓名和数字均被一个空格隔开。

输出

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.
对每一个测试用例,将你的结果用N行输出,每一行代表一个学生,以如下格式输出:首先输出学生的姓名,然后是该学生所选的课程的总数量,最后将所选的课程以递增的序列输出。查询学生的输出顺序必须与输入时的学生姓名顺序一致。所有在同一行的数据必须要用空格隔开,每一行的最后没有多余的空格。

样例输入

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

样例输出

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

思路

这道题目的是让我们熟悉vector的用法,让我们能更好的理解变长数组的概念,可以看到每个学生选的科目的数量是不一样的,那么可以把一个学生作为一个结构体存储利用vector存储所选的科目。另外这里还用到了一个字符串hash的概念,将规模固定的字符串唯一的映射成一个数字。题目中形式固定(3个字母加一个数字)的学生名字可以唯一的映射成为一个数字作为结构体数组的下标,在对应的结构体中进行存储。这也是用空间换时间的一种策略,毕竟如果用一般的方法遍历查找的话数据规模一大起来就超时了。我们也可以算出这样做(采用26进制法)最多需要26 x 26 x 26 x 10 = 175760个结构体,四舍五入一下所需结构体数量就是180000个了。剩下的就是读入数据进行存储然后将课程进行排序了。

解答

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<vector>

using namespace std;

struct students{
	vector<int> course;
}student[180000];

int change_name_to_int(string name){
	return (name[0] - 'A') * 26 * 26 * 10 + (name[1] - 'A') * 26 * 10 + (name[2] - 'A') * 10 + name[3] - '0';
}

int main(void){
	int N,K;
	int course_num,std_num;
	string name;
	while(~scanf("%d%d",&N,&K)){
		for(int i = 0; i < K; i++){
			scanf("%d%d",&course_num,&std_num);
			for(int j = 0; j < std_num; j++){
				cin >> name;
				student[change_name_to_int(name)].course.push_back(course_num);
			}
		}
		for(int k = 0; k < N; k++){
			cin >> name;
			int number = change_name_to_int(name);
			sort(student[number].course.begin(), student[number].course.end());
			cout << name << " " << student[number].course.size() << " ";
			for(int l = 0; l < student[number].course.size(); l++){
				cout << student[number].course[l];
				if(l != student[number].course.size() - 1) cout << " ";
			}
			cout << endl;
		}
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值