1039 Course List for Student (25分)

题目

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N ( ≤ 40 , 000 ) N(\le40,000) N(40,000), the number of students who look for their course lists, and K ( ≤ 2 , 500 ) K(\le2,500) K(2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 1 1 to K K K) in the following format: for each course i i i, first the course index i i i and the number of registered students N i ( ≤ 200 ) N_i(\le200) Ni(200) are given in a line. Then in the next line, N i N_i Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N N N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N N N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

题目大意

模拟数据库操作的题目,给出学生的选课信息,再根据这些信息找出某个学生选了多少门课,选了哪些课;

思路

题目本身比较简单,看到题目我的第一反映就使用map做映射,写好代码提交,最后一个测试点超时,又改了半天依旧通过不了,于是百度了下,看到别人用的哈希表,瞬间有了思路,其实题目本身已经给出了提示,学生姓名有固定的长度和格式,如果单纯用map,没必要这样,这里其实就暗示用哈希做映射,知道了这个问题就迎刃而解了,下面上代码;

代码

#include <iostream>
#include <cstdio>
#include <set>
using namespace std;

const int MAXN = 26*26*26*10;
set<int> db[MAXN];  // 学生选课不可能重复,并且最后输出也需要排序,刚好用set合适
int transf(char *name){
    int s = 0;
    for(int i=0; i<3; i++){
        s = s*26 + name[i]-'A';
    }
    s = s*10 + name[3]-'0';
    return s;
}

int main(){
    int n, k;
    scanf("%d %d", &n, &k);
    for(int i=0; i<k; i++){
        int index, num;
        char name[5];
        scanf("%d %d", &index, &num);
        for(int j=0; j<num; j++){
            scanf("%s", name);
            db[transf(name)].insert(index);
        }
    }
    for(int i=0; i<n; i++){
        char name[5];
        scanf("%s", name);
        int t = transf(name);
        printf("%s %d", name, db[t].size());
        for(set<int>::iterator it=db[t].begin(); it!=db[t].end(); it++)
            printf(" %d", *it);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值